Error: While Running The Sample on DRIVE PX2 from Nsight Eclipse

Hi,

I get the following error, when I click on ‘Run’ to launch ‘DriveNet’ application on target (Drive PX2) from host (Run->Configuration from Nsight). However, able to Upload local executable to target.
But not able run from host. Please let me know.

Last login: Thu Mar 8 08:51:10 2018 from 172.27.40.73
echo $PWD’>’
/bin/sh -c “cd “/usr/local/driveworks/bin-nsight”;export LD_LIBRARY_PATH=”/usr/local/cuda-9.0/lib64":${LD_LIBRARY_PATH};export NVPROF_TMPDIR="/tmp";export DISPLAY=“0”;"/usr/local/driveworks/bin-nsight/sample_drivenet"";exit

Welcome to Drive Linux running on Ubuntu 16.04!

nvidia@nvidia:~$ echo PWD'>' /home/nvidia> nvidia@nvidia:~ /bin/sh -c “cd “/usr/local/driveworks/bin-nsight”;export LD_LIBRARY_PATH=”/usr/local/cuda-9.0/lib64":${LD_LIBRARY_PATH};export NVPROF_TMPDIR="/tmp";export DISPLAY=“0”;"/usr/local/driveworks/bin-nsight/sample_drivenet"";exit
nvrm_gpu: Bug 200215060 workaround enabled.
WindowGLFW: Failed initialize GLFW
terminate called after throwing an instance of ‘std::exception’
what(): std::exception
Aborted (core dumped)
logout

Thanks.

Dear sachin.joshi,

What kind of graphics devices did you set up?
If iGPU, could you change the setting to dGPU with export CUDA_VISIBLE_DEVICES=0?

Hello SteveNV,

Tried with, dGPU with export CUDA_VISIBLE_DEVICES=0
And iGPU with export CUDA_VISIBLE_DEVICES=1
Still facing the same error.

Thanks.

Dear sachin.joshi,

Could you please help to re-check your development environment and setting with below link? Thanks.

Dear SteveNV,

This is resolved. There was a typo error while setting up environment variable/value.

Thanks.

Hello Sachin ,

Could you please share what was the enviroment variable that was setup wrong in you case?

I might be doing the same mistake .

Thank you

Dear ramtej.bejugam,

Could you please refer to the following link for your topic?

https://developer.nvidia.com/drive/learn/tutorial-NsightEclipse