Error while starting the riva speech services server

Please provide the following information when requesting support.

Hardware - GPU - NVIDIA RTX 3090
Hardware - CPU - Intel(R) Core™ i9-10900X CPU @ 3.70GHz
Operating System - Ubuntu 20.04
Riva Version -2.3.0

Able to run bash
Getting error when running bash

Below is the riva init log file
riva_init_log.txt (6.5 KB)

Below is the error picture

And even modified the file by going through the similar topics which are mentioned previously, attaching the modified config file below (14.1 KB)

I had to clean and re-init riva to solve this when it happened to me.


1 Like

Thanks for your reply, but I even tried that too, its the same again

Hi @manjunathkondamu

Thanks for your interest in Riva

Apologies for the delay

Thanks for sharing the the config and riva_init logs

Thanks @vanessa.crosby for the suggestions

Have one request,
when running the, Kindly request to open another instance/terminal,
Run the below command
docker logs riva-speech
and share the output as txt file in this thread (collecting the output at end or last will be helpful)


Hi @rvinobha

Thank for your reply

As you mentioned it, i have run the command and took the both stderr and stdout into one log file,

Command : sudo docker logs riva-speech &>! logs.txt

below is the attached log file

logs.txt (44.8 KB)


I am getting the same issue, how did you solved it?

Didn’t solve it at, waiting for the reply

I cleaned up the environment and it worked.

1 Like

Thanks for the suggestion, but I did try the same and the results were same.

Hi @manjunathkondamu

Apologies for the delay

We suggest you to install Update/install Nvidia Driver Version - 510+
Current Driver Installation from logs - 470

Please update the driver, run bash and try again, and let us know if it works

Please find the support matrix link below for reference

Thanks for your patience