ESRI ArcMap Crashing | NVOGLV32.DLL

We use ESRI ArcGIS Desktop 10.8.2 at our organization.

At roughly the same time, multiple users began reporting the app crashing at launch (with varied hardware configurations, different OSes, driver versions and physical locations).

The crash dumps from many of them point to nvoglv32.dll as the location of the fault and disabling the nvidia gpu (on the machines with on-board graphics available) is a temporary workaround.


  •                                                                         *
  •                    Exception Analysis                                   *
  •                                                                         *

Failed to request MethodData, not in JIT code range


Key  : AV.Fault
Value: Read

Key  : Analysis.CPU.mSec
Value: 4249

Key  : Analysis.Elapsed.mSec
Value: 6921

Key  : Analysis.IO.Other.Mb
Value: 0

Key  : Analysis.IO.Read.Mb
Value: 0

Key  : Analysis.IO.Write.Mb
Value: 1

Key  : Analysis.Init.CPU.mSec
Value: 265

Key  : Analysis.Init.Elapsed.mSec
Value: 34440

Key  : Analysis.Memory.CommitPeak.Mb
Value: 177

Key  : CLR.BuiltBy

Key  : CLR.Engine
Value: CLR

Key  : CLR.Version
Value: 4.8.9181.0

Key  : Failure.Bucket
Value: INVALID_POINTER_READ_c0000005_nvoglv32.dll!Unknown

Key  : Failure.Hash
Value: {31efe6d8-bd30-e286-103b-1a498a3fb31a}

Key  : Timeline.Process.Start.DeltaSec
Value: 8

Key  : WER.Process.Version

FILE_IN_CAB: ArcMap_10.9.1.28388_0_01_05_2024_09_48_42.dmp

CONTEXT: (.ecxr)
eax=00000044 ebx=641730f8 ecx=00000064 edx=00000000 esi=06f972c5 edi=0629ffff
eip=632633d7 esp=00afc120 ebp=00afc13c iopl=0 nv up ei pl nz na pe nc
cs=0023 ss=002b ds=002b es=002b fs=0053 gs=002b efl=00010206
632633d7 8a07 mov al,byte ptr [edi] ds:002b:0629ffff=??
Resetting default scope

ExceptionAddress: 632633d7 (nvoglv32+0x00c633d7)
ExceptionCode: c0000005 (Access violation)
ExceptionFlags: 00000000
NumberParameters: 2
Parameter[0]: 00000000
Parameter[1]: 0629ffff
Attempt to read from address 0629ffff


READ_ADDRESS: 0629ffff

ERROR_CODE: (NTSTATUS) 0xc0000005 - The instruction at 0x%p referenced memory at 0x%p. The memory could not be %s.




WARNING: Stack unwind information not available. Following frames may be wrong.
00afc13c 6326336f 06f972c4 0629ffff 00000000 nvoglv32+0xc633d7
00afc150 62dfc869 06f972c4 0629ffff 070e7458 nvoglv32+0xc6336f
00afc2d8 06f972c4 0629ffff 070e7458 06f58730 nvoglv32+0x7fc869
00afc2d8 0629ffff 070e7458 06f58730 06f58701 0x6f972c4
00afc2d8 070e7458 06f58730 06f58701 75587343 0x629ffff
00afc2d8 06f58730 06f58701 75587343 3233646d 0x70e7458
00afc2d8 06f58701 75587343 3233646d 3737315f 0x6f58730
00afc2d8 75587343 3233646d 3737315f 642e3630 0x6f58701
00afc2d8 62e34455 6443196c 64431970 00afc2f0 shell32!wkscli_NULL_THUNK_DATA_DLA (shell32+0x647343)
00afc2fc 6443196c 64431970 00afc2f0 64431974 nvoglv32+0x834455
00afc2fc 64431970 00afc2f0 64431974 00000000 nvoglv32+0x1e3196c
00afc2fc 00afc2f0 64431974 00000000 00000000 nvoglv32+0x1e31970
00afc2fc 64431974 00000000 00000000 62e33a10 0xafc2f0
00afc2fc 00000000 00000000 00000000 00000000 nvoglv32+0x1e31974

STACK_COMMAND: ~0s; .ecxr ; kb

SYMBOL_NAME: nvoglv32+c633d7

MODULE_NAME: nvoglv32

IMAGE_NAME: nvoglv32.dll

FAILURE_BUCKET_ID: INVALID_POINTER_READ_c0000005_nvoglv32.dll!Unknown


OSNAME: Windows 8


FAILURE_ID_HASH: {31efe6d8-bd30-e286-103b-1a498a3fb31a}

Followup: MachineOwner


Hi @merkat106, welcome to the NVIDIA developer forums.

What was the trigger that caused this to happen? A synchronous GPU driver update? If so, does it help to roll back the GPU driver?

Or was it the update to a new version of ESRI ArcGIS Desktop?

What kind of GPUs do your machines have and what GPU drivers do you deploy?

Looking at

OSNAME: Windows 8

tells me this is driver 546.33 which is not supported on Windows 8 .


We do not know the cause as it happen around the same time Friday - and the driver versions were different on many of the machines.

We are on the highest version of ArcGIS Desktop - no updates available. We have also updated the drivers after the fact with no resolution.

And the debugger used on the dump files is showing as Windows 8 despite the problem occurring on both Windows 10 and Windows 11 machines.

So far, we isolated the issue to machines with NVIDIA GeForce GPUs.

Machines with AMD Radeon or NVIDIA Quadro do not seem affected, but those devices seem to be in the minority in our organization.


Hi. I don’t suppose you solved this one or made any progress?
We are having the exact same issue at our organisation and I have just come across your post whilst looking into it. It looks like our problem began at the same time as yours.
We have found that if we disable the NVIDIA driver then ArcMap will launch fine but this is not a viable solution.

1 Like

Hello @andy_cun and welcome to the NVIDIA developer forums.

and the driver versions were different on many of the machines.

This makes helping/debugging very difficult.

It is basically that some amount of machines running this specific software AND use some NVIDIA GPU, not Quadro, with DIFFERENT driver versions suddenly decide to throw this error.

Could you possibly try to find another common factor? Some other third party software that was installed, some Windows update, anything. Did you talk to the ESRI ArcMap support yet?

1 Like


I created a “fix” since ESRI didn’t get back to us with an answer.

Since I know the NVIDIA Open GL x86 driver was at fault, I did the following:
I modified a current GeForce driver by uncompressing it and replacing nvoglv32.dll with one from an older installer.
Completely removed the installed display drivers with Display Driver Uninstaller
Then installed the “modified” driver package on the machine

ArcMap now runs normally - for now…

I suspect the Open GL driver is getting modified by Microsoft Update as an explanation why despite different driver versions existing on a non-updated ArcGIS Desktop, ArcMap crashed at roughly the same time.

1 Like

That will break driver signature, but if that is not required and it works…

I wonder, just replacing the OGL DLL works but taking the complete older driver package does not? Weird.

I asked around internally if there is some known issue that would fit this situation, but still have to hear back.

1 Like

It probably does -
Then Windows Update changes something in that open gl driver during an update that ArcMap can’t cope with.
Disabling driver update would break other apps so disabling it is not an option.

Driver signature is broken, but it doesn’t impede usage.

1 Like

To engineering this issue was completely knew, but I received some input on how to go about trying to figure out if it was connected to Windows Update. I copy this verbatim, I hope it helps:

It would make sense to look into the Microsoft Update history on the affected machines and see if they all installed the same update at that day when the failures started and provide the update package numbers.

If a Microsoft Update caused the issue it would make sense to test if uninstalling that update fixes the issue.

If not, it would make sense to repeat the display driver cleaner step again and install an official (non-hacked) driver package which was known to work again to see if that solves the issue.

If yes, try updating the display driver to the newest available version for that configuration and see if things still work.

If yes, open the NVIDIA Control Panel, click on System Information and Save them to a file.
That doesn’t contain the version info details of the nvoglv32.dll, so find that inside the Driver Store and right click and Show Properties and select the Details tab.
Make sure the version number matches the version numbers of the saved NV CPL system information modules.

If the failure started with a Microsoft Update, install that update package again. Try if ArgGIS fails again.
Repeat the above steps with the NV CPL system information and the nvoglv32.dll version.
If the version numbers of any of the display driver files changed, and especially if they are not matching anymore, that Microsoft Update is incorrect and needs to be omitted by the system administrators.

1 Like

Hi @MarkusHoHo
Users in our org have also seen this issue as of today. We are currently in a Windows update change freeze since before Xmas. Strangely, the only update that I can see on some affected machines is an Adobe Acrobat Reader update (on my machine it has possibly gone from a 32bit → 64bit version).

Testing on my machine, when I remove the Nvidia driver I’m able to open ArcMap again, as soon as I install version 538.15 the crashing occurs on the next instance. I’ve attempted to follow your instructions above and these are the values i’m seeing:
nvoglv32.dll - File version

A workaround for us at the moment is to disable a secondary Intel display adaptor which the laptops have. This allows for ArcMap to load without issue.

The previous Nvidia version on my machine was 528.XX. Many thanks for your help.

I should also note, all our machines are Intel based laptops. Our graphic units are a combination of Quadro RTX 3000 and RTX A1000 Laptop GPUS.

I’ve since managed to get my machine working (Quadro RTX 3000) on the non DCH version:

1 Like


Users at our organisation have also encountered the same issue as others in this feed.
It is quite odd as users had been using ArcMap last night successfully and when they logged in this morning and restarted ArcMap to work on another project the issue was encountered. This was then further reported by other members of the organisation.

After comparing specs on the machines affected by this, I have found the following:
“Working” : [
“OS” : “Microsoft Windows 11 Enterprise”,
“Version” : “10.0.22000 Build 22000”,
“Processor” : “Intel(R) Core™ i7-6700 CPU @ 3.40GHz, 3401 Mhz, 4 Core(s), 8 Logical Processor(s)”,
“Graphics_Card” : “NVIDIA GeForce GTX 970”,
“Installed Drivers” : “C:\Windows\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_866484083fc526af\nvldumdx.dll”,
“DLL” : “nvoglv32.dll”,
“DLL_File_Description” : “NVIDIA Compatible OpenGL ICD”,
“DLL_Version” : “”,
“ArcMap” : “10.7.1”
“Not_Working” : [
“OS” : “Microsoft Windows 11 Enterprise”,
“Version” : “10.0.22631 Build 22631”,
“Processor” : “AMD Ryzen 9 5950X 16-Core Processor, 3401 Mhz, 16 Core(s), 32 Logical Processor(s)”,
“Graphics_Card” : “NVIDIA GeForce RTX 4090”,
“Installed Drivers” : “C:\Windows\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_72a60bcfb646da4c\nvldumdx.dll”,
“DLL” : “nvoglv32.dll”,
“DLL_File_Description” : “NVIDIA Compatible OpenGL ICD”,
“DLL_Version” : “”,
“ArcMap” : “10.7.0”
“OS” : “Microsoft Windows 10 Enterprise”,
“Version” : “10.0.19045 Build 19045”,
“Processor” : “AMD Ryzen 9 5900X 12-Core Processor, 3701 Mhz, 12 Core(s), 24 Logical Processor(s)”,
“Graphics_Card” : “NVIDIA GeForce RTX 3080”,
“Installed Drivers” : “C:\Windows\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_866484083fc526af\nvldumdx.dll”,
“DLL” : “nvoglv32.dll”,
“DLL_File_Description” : “NVIDIA Compatible OpenGL ICD”,
“DLL_Version” : “”,
“ArcMap” : “10.7.0”

Other machines which are not using Nvidia have not shown any issues.
The only thing I see different between the above is that the driver had no issues on a cpu running an Intel chip whereas those running on an AMD processor share the issue.

Similar to other users here, our IT dept was in a change freeze during this time, and no updates were installed last night (that we are aware of) regarding Windows Updates, graphics driver updates, ArcMap patches. This of course makes this whole situation incredible vexing.

Our interim solution has been to disable the Nvidia Display Driver in Device Manager which then does allow ArcMap to open, however as these machines are purpose built for modelling, this is not an ideal solution.

Open to any and all suggestion.


1 Like

We had users experiencing the same issue. This time for Quadro P600. We first resolved the issue by disabling the Display adapter in Device Manager. That resulted in ArcMap opening correctly, but that obviously limits the machines capabilities using the generic Intel Driver. So we followed that up by installing NVIDIA RTX / Quadro Desktop And Notebook Driver Release 470 and the issue was resolved with that driver.

1 Like

Having same issue with:
DirectX version: 12.0
GPU processor: Quadro RTX 4000
Driver version: 538.15

1 Like

For what its worth, we had this exact same problem (with ArcMap, but a few other programs as well) for the past day or so. Magically, today at 2:50 PM Central time, it started working for everyone, at the exact same time. (hands up) – I have no idea, and cannot explain this.

1 Like

We have returned after the weekend, and this has been our experience as well. Users who were having issues with the app crashing on startup (Friday), are now happily opening it like nothing ever happened. Unsure what to make of that.

1 Like

Welcome everyone ho is new to the thread and thanks for reporting that you had similar issues.

And thanks @JeradW and @CavalettaNZ for the feedback that it “fixed itself” somehow.

I opened an internal bug to track this as well and see if our engineering/QA team can reproduce and hopefully get to the bottom of this.



Just bumping this as my team appears to have run into this issue after a windows update over last week or weekend… We use ArcGIS 10.6.1, Disabling our Nvidia display drivers allows ArcMap to open with the integrated display driver. Not ideal as the computers are used for game development/modeling. If you think I can provide some new information let me know.

1 Like

Hi @mxperrr
It would appear that ESRI have been in contact with NVIDIA (which is great!) as posted here:
Solved: Arcmap Crashes All of the Sudden Instantly on All … - Esri Community

I’d suggest trying out that driver that is mentioned and see how you get on.
Good luck!

1 Like