Ethernet port unable to achieve full gigabit connection

Hi all,

One of our new orins has been experiencing significant performance issues with the ethernet port, which as I understand is capable of up to 10G. Despite freshly reflashing, our ethernet cannot exceed a 100baseT connection using the same connection our other orins use to achieve a full gigabit connection. Is there anything that can be done regarding this issue? We run L4T35.1.0 stock flashed using the sdk manager and have other orins running the same configuration with no issues.

We have tried to investigate anything in the kernel logs and network activity, but have not found anything that provides information on why this issue is happening. We believe that the device’s ethernet port may be faulty, are there any recommendations on what we can further explore to troubleshoot this problem? We have been trying to figure out what’s wrong for some time now and have not made any significant progress.

Any advice or assistance on this matter is welcomed and greatly appreciated!

Stephen Abraham

Upgrade to 35.3.1 first.

Dump the result of ethtool eth0 if the issue is stillt there.

Was this a known issue that was resolved in 35.3.1? we have all our other orins still running 35.1.0 and hence why we are wary about upgrading quite yet. I can provide a dump on the current installation and then give that a try if it will really help

We don’t debug on old release. So upgrading to latest one is the basic step when doing debug.

If you don’t want to upgrade, then share me the ethtool result on your current release too.

Oh, I did not realize that - is this a new change over the past year? just a curiosity question since I have not used these forums for some time now.

I have attached the ethtool output from our current installation:
for reference, it’s connected to a gigabit switch with a compliant ethernet cable.
orin_ethtool_output.log (1.7 KB)

There’s your problem, it didn’t select gigabit:

Speed: 100Mb/s

Since it is auto negotiated it may not be related to the Jetson itself (or it might be). I’ve had both Jetson and non-Jetsons (several) not auto negotiate gigabit, but easily function correctly when manually set.

One way to manually set is the GUI tool “nm-connection-editor” (“sudo apt-get install network-manager-gnome” if you dont’ have it). For manual setup, see this URL:

The specific line of interest is this (adjusted to be eth0):

sudo ethtool -s eth0 autoneg on speed 1000 duplex full

(I sometimes turn off autoneg, depends on the circumstances)

1 Like

As linuxdev said
It looks like the link partner advertised link speed does not have anything else > 100.
Jetson side still has capability to reach 10G but the link partner side does not support it.

Link partner advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full

I don’t know if this is just network environment problem. For example, I have a very cheap hub which only supports up to 100M and it will show the same situation as yours.

Additional note: Both the remote system and intervening switch can limit what the auto negotiation results in. I’ve seen some switches with the same capability which end up defaulting to lower speeds than others despite all of them supporting the same maximums. In those cases manual change of speed works, but it can be confusing why switches and/or NICs don’t default to their maximums in all cases.

Hi @linuxdev and @WayneWWW,

That was also my initial conclusion, which is why I tried to isolate the issues as much as possible such as testing multiple orins on the same switch on the exact same port with the same ethernet cable. I have also manually established the connection, but this has not resolved the problem either. I have also attempted several re-flashes thinking it may have been a configuration issue that I accidentally introduced, but that was not the case either.

To clarify, this exact connection setup had been tested and used on all other orins that we have.

The attached log is when I manually establish the gigabit connection.
ethtool_linuxdev_test.log (1.0 KB)

Do you have other environment to test? Or just connect 2 jetson port to port directly.

I’m really surprised to see this from the ethtool log:

Speed: Unknown!
Duplex: Unknown! (255)
Port: Twisted Pair

Is this using ordinary ethernet cabling, e.g., CAT 5e or 6? Also, according to that log, it probably did not achieve gigabit…it might have, but there is some sort of error making it impossible to know.

I have tested inside of a different environment before where I was testing on a mobile network modem and that is actually where I first noticed the problem. I have not connected two jetsons together yet, so far it has entirely been testing two jetsons using the same ethernet port on the same switch - is that something I should be trying?

Yeah I have tried using a few different ethernet cables, the current one is a CAT6 cable and all the previous ones were also CAT6.

Comparing all these tests with this particular orin agx and all of our other ones is what leads me to believe there is something wrong with the ethernet port itself. is there any recommended tests that I could try to exclusively rule or confirm this ?

I couldn’t tell you of a specific test. Flashing again and looking for whether or not ethtool can see the speed/duplex/port correctly (perhaps using a different release) would be good information (it might be software and not hardware at issue). One thing I would consider for hardware is to use a magnifying glass and look closely at all sockets and connectors at all ends to see if anything is bent or broken.

Okay, I will try to re-flash it again, but I feel that the outcome will remain the same. If that is the case, what would the next steps be?

Sorry for the late response. Then you would probably try to RMA. For a system sold by NVIDIA (versus a third party vendor) here is the RMA FAQ:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.