EVGA 1080 Ti FTW3 Asynchronous Fan Control Nonfunctional under Linux

I am posting here rather than on the EVGA forums as I believe this is a driver-related problem, and EVGA has indicated previously that NVIDIA support should be contacted instead of them for Linux-related issues (see here, I have also tried the steps in this thread)

My EVGA 1080 Ti FTW3 contains three fans, each handling a separate thermal zone. The fans are designed to cool their own zones when needed. However, under Linux, only the “GPU” thermal zone is recognized.

This is problematic because regardless of how much I stress the 1080 Ti under Linux, by default only the “GPU” fan spins. Eventually the card throttles itself due to the “Power” and “Memory” thermal zones receiving inadequate cooling.

I am running Ubuntu 17.04 with a Ryzen 1800X CPU, and I have tried both the default 375.66 driver as well as the newest 384.47 driver. I believe this is a Linux driver issue as the “Power” and “Memory” fans spin up appropriately under Windows without having to install or run any extra EVGA software.

I have discovered a workaround to at least make the other fans spin for now. Disabling auto-fan speed and setting the “Power” and “Memory” fans to a fixed percentage under Windows using EVGA’s software does cause them to spin under Linux, although I can’t increase or decrease the speed when appropriate.

I would like for either the fans to work as they do by default under Windows, for the Linux driver to expose all three fans separately under their appropriate thermal zones, or expose one fan but have it actually control all three.
As EVGA seems to be making more models with asynchronous fan control, this could become a bigger issue in the near future. I believe the FTW3 and the SC2 in the 1080 Ti line are currently affected.

On a side note, the NVIDIA X Server Settings’ PowerMizer performance level Max Graphics clock seems too high at 1999MHz vs the stock boost clock under Windows at ~1742MHz.
nvidia-bug-report.log.gz (146 KB)

It appears that Asynchronous Fan Control does actually work, turns out I wasn’t actually stressing the “Memory” and “Power” thermal zones enough. Running SaschaWillems’ computeshader Vulkan demo put enough load on the VRAM that at least that fan started spinning.

I will mark this as solved, although it would be nice to have some method of controlling all three fans manually/synchronously under Linux rather than having to reboot. EVGA likely does something proprietary here, so I won’t expect a driver solution directly from NVIDIA.