Expansion Header Tool no longer opening

I’ve been accessing the Expansion Header tool on my Jetson AGX Orin no problem for the last few months, but today it stopped working.

I ran “sudo /opt/nvidia/jetson-io/jetson-io.py” to access it, then enabled PWM on pins 15 and 18. I saved the configuration and selected the option to “Exit without rebooting.” I then rebooted the machine a few minutes later and tried to get a PWM output out of pins 15 and 18, but to no avail. So I attempted to open the expansion header tool again. But now, when I run “sudo /opt/nvidia/jetson-io/jetson-io.py”, the tool pops up briefly and then closes. So PWM is not enabled properly on pins 15 and 18 and I can’t open the header tool to try and re-enable them. I should also clarify that I had PWM running fine on pins 15 and 18 earlier today, but disabled them to test something else. Any help is much appreciated, thank you!

1 Like

Please check if it works by re-flashing Orin developer kit. We have released Jetpack 5.1 and you can upgrade to this version.

The purpose of jetson-io.py is for debugging. You can generate the device tree quickly without modifying source code and rebuilding kernel. It is possible it does not work properly if you dynamically generate the device tree for multiple times.

We would suggest use jetson-io.py for development. For a real product, please modify source code to customize kernel to fit the hardware board.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.