Error on Jetson Orin

Hello, I’m new to Jetson machines, and I would like to use pin40 header (for custom SPI devices).
I ran /opt/nvidia/jetson-io/, and got this error message:

Traceback (most recent call last):
  File "/opt/nvidia/jetson-io/", line 25, in <module>
    from Jetson import board
  File "/opt/nvidia/jetson-io/Jetson/", line 28, in <module>
    import Headers
  File "/opt/nvidia/jetson-io/Headers/", line 34, in <module>
    if hdr.HDR.default:
AttributeError: module 'Headers.__init++' has no attribute 'HDR'

I searched “jetson-io for orin”, and according to this post, Orin doesn’t support Also, it seems like some dtb files are missing, so I need to get them from kernel source codes.

Are there any updates I could download to get jetson-io working? I think jetson-io is a really helpful tool, especially for people like me who don’t have much experience in embedded system.

Just to confirm, to get things working, I need to download kernel source codes (Board Support Package), build the kernel image, build kernel modules, copy the kernel image to the /boot directory, and finally reboot. Is this procedure correct?

I’m pretty new to this area, any help or advice is highly appreciated!

Hey, I ran into the same issue. The only way I could make any of the I/O work as expected is by creating a config with the pinmux excel sheet and reflashing. You can use devmem in Busybox, but it doesn’t seem to work in all cases

Will be available for next release. (J5.0EA)

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.