External monitor freezes when using dedicated GPU

@generix @j22gim
Hopefully, I am not Jinxing anything now … but I have used 510 for 30min+ now without any freees.
What I found weird is that it looks like both 510 and 525 are installed:

apt list --installed | grep nvidia-driver

nvidia-driver-510/jammy-updates,jammy-security,jammy,now 525.125.06-0ubuntu0.22.04.1 amd64 [installed]
nvidia-driver-525/jammy-updates,jammy-security,jammy,now 525.125.06-0ubuntu0.22.04.1 amd64 [installed,automatic]

Anyhow, I worked my way down doing

sudo apt install nvidia-driver-545
sudo apt install nvidia-driver-535
sudo apt install nvidia-driver-530
sudo apt install nvidia-driver-525
sudo apt install nvidia-driver-520
sudo apt install nvidia-driver-515
sudo apt install nvidia-driver-510

In between each new install, I did:

sudo apt remove -y nvidia-driver-* nvidia-* libnvidia-* libnvidia-*:i386 xserver-xorg-video-nvidia-*; sudo apt autoremove -y
reboot

Finally! I do hope this driver does not cause any more freeze issues.

Not that it’s a bug report, more like an “It’s all good”-report, but I’ll attach one if e.g. @amrits wants to have a look:
nvidia-bug-report_510.log.gz (529.6 KB)

2 Likes

Im not sure if this help but changing the external monitor to 60hz seem to have fixed the issue since changing the size of glxgears did not make it hang.

I first had 144hz on the external monitor, started glxgear and wiggled the size around and it froze. With xrandr i switched the external screen to 60, it came back, i did the same procedure and couldnt get it to freeze.

For what its worth im attaching one log when its at 60hz and one log when its 144hz.

nvidia-bug-report.log.144hz.gz (1.2 MB)
nvidia-bug-report.log.60hz.gz (1.1 MB)

2 Likes

@simpson38, thanks good job!

I didn’t pay attention to this, but my list of Refresh Rates is weird - initially I had fancy 60.01 Hz on Display and 60.00 Hz on external, that caused the issue. Now I’ve selected 119.94 Hz on Display and glgears resizing still jerking from time to time, but that doesn’t cause external display to freeze!

I also tried my previous scenario with Gimp plus nvidia-offloaded app and it now has similar behavior - jerks but doesn’t freeze whole screen.

So I guess, bottom line - refresh rates need to be in tact with each other…

Can someone explain, why I never have those fancy refresh rates like 60.01 Hz option with Windows driver but do have them in Linux version? Is that a feature or a bug?

1 Like

I jinxed it …
nvidia-bug-report_510.log.gz (450.5 KB)

I connected to another screen today, used it for a while, and then it froze. I do not know yet if it will freeze on the monitor I used yesterday.

@simpson38 a good discovery! However with my setup, I only use the external screen my laptop screen is dark, and the lid is closed, so I only have one screen, and I still have the freeze. But thanks for the tips of setting --rate 60 with xrandr

One other discovery which might be relevant!
My internal screen has allways been named eDP-1 and my external HDMI-1-0
However, yesterday when it all worked (at least for some hours) they were named eDP-1-1and HDMI-0
Today when I got the Freeze for the first time I noticed the naming was back to the original.
I know this because I am using i3 so I kave hot keys like
bindsym $mod+Shift+p exec xrandr --output HDMI-1-0 --off --output eDP-1 --mode 2560x1440 --rate 60
and
bindsym $mod+Shift+i exec xrandr --output eDP-1 --off --output HDMI-1-0 --mode 3840x1080 --rate 60

One way, for me, to reproduce the Freeze is to hit Super + Shift + R which causes i3 to refresh.

Hello, everyone. I’ve been experiencing the same issue with my RTX 4050 and Dell G15(kubunt 22.0.4) laptop since 20/10/23.

When I move tabs from one monitor to another and maximize them, my laptop freezes for 1-2 seconds, and then it returns to normal, but my second monitor remains frozen.

It can be happen also when i am trying to maximize the youtube tab from chrome.

The only solution I’ve found is to deactivate and then reactivate the external monitor every time this happen…

I’ve tried just about everything you can imagine, and I’ve even downgraded to the 510 drivers as suggested in the comments above, but the problem persists.

None of the 545, 535, or 525 drivers have worked for me.

This is incredibly frustrating as this is my work laptop, and I rely on an external monitor for my work.
nvidia-bug-report.log.gz (675.2 KB)

2 Likes

I am unfortunately not able to reproduce issue locally on couple of notebooks with NVIDIA GeForce RTX 4060 Laptop GPU after trying same steps as mentioned by @ursom
I will test on few other config notebooks and update.

@tsikas80s I hear you :( it’s the same for me. If I can’t use external monitor, my whole laptop is kind of useless…
@Spange good idea with the shorcut keys!!

In my case, I was doing fine at home, no more freezing. But now I’m back at the office and I found something very weird, which only happends if the laptop monitor is not at its full resolution.

The max resolution in my case (and also the default one, when I set the external monitor as extended of the laptop monitor in my Monitor Settings app) is 2560 x 1600

But this resolutions makes everything ridiculously small for my tasks, so I always lower it to 1920x1200. At home (LG screen) I had no problems doing that, but with this other external monitor (Samsung) this happens:

When I set the resolution to 1920x1200, the 2nd monitor does not freeze, but the mouse pointer is trapped within the primary display only!! Everything in the 2nd monitor works fine (I can do whatever is possible using the keyboard), but I can not use the mouse on this monitor. If I switch back the resolution to maximum, everything works fine again… Weird!

PS. as a reminder, I am using 525 drivers, here’s the story

@j22gim are you able to open the Display settings?
My aim is that maybe the 2nd monitor gets moved to a really awkward position, and that when you try to move the cursor onto it is not there. E.G: your monitor is left of your laptop, but the settings say right.

Here is a command you can play with:
xrandr
E.G.:
xrandr --output eDP1 --preferred --rate 60 --output HDMI-1-0 --mode 1920x1200 --rate 60 --left-of eDP-1

I have an update to share.

I’ve been able to replicate the freezing issue on the external monitor when spamming the ‘f’ key while watching YouTube. I repeated this action ten times, and after a while, when I continued spamming the ‘f’ key to maximize and minimize the full-screen mode, the external monitor froze.

Here are the logs
nvidia-bug-report.log.gz (577.0 KB)

1 Like

This same issue started happening to me just yesterday on Zoom calls, then other unpredictably random times. Just like @tsikas80s I am able to trigger it 100% of the time by spamming the ‘f’ key watching YouTube. Simply opening display settings and making any change at all and then choosing to not accept the change seems to kick things back into gear. My laptop is an HP ZBook and I have two external monitors on an HP docking station. Not sure what it means, but whichever monitor I happen to have video playing on is the one that freezes. I’ve switched from Wayland to XOrg and have tried several Nvida drivers and the problem persists.

2 Likes

If you are you able it would be welcome with logs. from nvidia-bug-report.sh

nvidia-bug-report.log.gz (587.7 KB)

1 Like

Same problem, aggressive freezing started only a couple of days ago. Got to the point where it was easier to just stop using external monitors than deal with the freezes.
I am also able to reliably reproduce by spamming ‘f’ (full screen toggle) on youtube. (Has taken up to 30 Fs to trigger, but it’ll get it every time)
Asus laptop with 4060. Running Linux Mint 21.2, kernel 6.2.0-34-generic (changed a few times to see if it helped. It didn’t)
Original configuration was laptop closed, with hdmi to asus monitor, usb-c displayport to multi-stream-transport dell<>dell for triple monitor.
Crash report generated with only hdmi attached, fewer monitors seems to have fewer chances to trigger.
nvidia-bug-report.log.gz (611.9 KB)

2 Likes

Hmmm strange, I can’t reproduce the ‘F’ key case for some reason, it’s not even jerking like other apps…
I’ve tried regular and offloaded firefox developer’s edition on display and external screen… it may depend on particular model (RTX 40xx only?) or on composition of where apps are displayed maybe…

  • What browser are you using?
  • Is it offloaded or running on intel graphics?
  • Are there other apps on any displays?
  • Are you running youtube on external screen?

Also I would like to take my previous statement back - changing Refresh Rate make it harder or easier to freeze with glgears resizing, but sooner or later it still freezing. So that solution is not a ‘permanent’ fix for me :/

I can confirm, that, at least for me, downgrading the drvier from
545.23.06
to
525.125.06

fixes the freeze issue for me.

Same for me after last update. I’m downgrading from 545, now I’m using this version

nvidia-driver-525/jammy-security,jammy-updates,jammy,now 525.125.06-0ubuntu0.22.04.1 amd64

It still happens once at 30m-1h on both external monitors (one HDMI and one usb-c connected)

1 Like

Well, I can reproduce this issue on either an external monitor or the laptop’s built-in monitor. Wherever it runs, if you spam the ‘f’ key while watching YouTube, the external monitor freezes. This happens 100% of the time when I try it. I am using the Google Chrome browser, and this issue occurs whether other apps are running or not. It also happens when you maximize and minimize the windows of the apps.

Changing the refresh rate doesn’t solve the problem. That was the first thing I tried when this issue started happening.

2 Likes

So annoying…
nvidia-bug-report.log.gz (401.4 KB)

Hi people, does it happen in your full / default resolution?

I also had to come back from 545 to 525.
I’m observing that, in my case, the freezing of the 2nd monitor only happens* when I lower the resolution of my laptop’s monitor (the external monitor is always 1920x1080). The refresh rate makes no difference.

  • well actually it is not freezing now, it’s weirder than that: it keeps working but the mouse pointer can not enter that screen

If I keep the laptop screen resolution at maximum (which is the default when I chose the 1+2 monitor settings), I have no freezing, and no errors whatsoever. But it also means I can not use the laptop monitor for text and work…

My full story in this post

1 Like

Are there any hits here?
It confuses me that it looks like nvidia-driver510 is the same as 515, 520, and 525 i.e. 525.125.06