External monitor not correctly recognised

My environment is Fedora 20 x86_64 running on a Lenovo W530 with nVidia K1000M graphics.

My usual setup has an IBM T221 monitor (“Big Bertha”, which can run at 3840x2400) connected via a short mini-display-port-to-DVI cable. I run the external monitor at 1920x1200 resolution.

I have usually installed kmod-nvidia-x.x.x from the rpmfusion repository, and updated kmod-nvidia at the same time as updating the kernel. (I only found out about the akmod-nvidia option recently.) But the problem described below is the same if I install kmod-nvidia, akmod-nvidia, or download the NVIDIA-Linux-xxxx.run installation script.

This configuration all worked well until “recently”, with the T221 correctly detected, and X running perfectly at 1920x1200. But possibly since a recent upgrade or two (I have been living with the problem for a few weeks) the external monitor is not detected correctly. It is detected as present, but X attempts to run at 5760x1080 (where the native W530 resolution is 1920x1080). As 1920x1080 is not a resolution supported by the T221, I get nothing on the monitor. When I run nvidia-setings, the screen layout seems to be “1920x1080 (the laptop screen), a 1920x1080 blank, and another 1920x1080 screen (the monitor)”

The standard nouveau driver correctly displays on the external monitor, so it is not a connectivity issue.

I haven’t had the chance to roll back kernel and driver levels to see if I can find out when the rot set in.

Is it possible that a recent change to the driver has caused this issue?

I should stress that I am not an expert in X and drivers, so please use short words!

Thanks in advance – Peter M

Hello,
same problem here, newest fedora 20 upgrades machine is:

HP Elitebook 8540w

card:
01:00.0 VGA compatible controller: NVIDIA Corporation GT216GLM [Quadro FX 880M] (rev a2)

installed driver:
NVIDIA-Linux-x86_64-340.58.run

And something I found, xrandr output looks strange, previously I did not have that many outputs… and VGA is not connected…

Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 8192 x 8192
VGA-0 connected (normal left inverted right x axis y axis)
1920x1080 59.93 + 40.09
LVDS-0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 345mm x 194mm
1920x1080 59.93*+ 40.09
DP-0 disconnected (normal left inverted right x axis y axis)
DP-1 disconnected (normal left inverted right x axis y axis)
DP-2 disconnected (normal left inverted right x axis y axis)
DP-3 disconnected (normal left inverted right x axis y axis)
DP-4 disconnected (normal left inverted right x axis y axis)
DP-5 disconnected (normal left inverted right x axis y axis)
DP-6 disconnected (normal left inverted right x axis y axis)

kernel:
Linux localhost.localdomain 3.17.4-200.fc20.x86_64 #1 SMP Fri Nov 21 23:26:41 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

Any one, any idea ? Really bad bug, I can’t connect my notebook to external displays… (auch).
Thanks in advance ! (an other Peter M --> funny :D)

some other topics about the same problem:

https://devtalk.nvidia.com/default/topic/784322/linux/nvidia-340xx-causes-flickering-desktop-no-dual-monitor-possible-no-hd-videos-on-archlinux-x-ubunt/2/?offset=40#4385730

https://bbs.archlinux.org/viewtopic.php?id=188118&p=1

Hello everyone !
New version do fix this problem !
And a big thanks for NVIDIA Support they were fast and superb !

http://nvidia.custhelp.com/app/account/questions/detail/i_id/713315

If you can’t see that, visit this link to download the newest version:
http://www.nvidia.com/download/driverResults.aspx/80647/en-us