Extremely slow download speeds for CUDA Toolkit

Hello,

I’m trying to download the CUDA Toolkit but its extremely slow. Is there any solution?

Slow speed in Linux and Windows.

Thanks in advance!

Henrik

Hi

For me it was very slow as well, i tried several times to stop the jetpack component manager and enable only the cuda toolkit download , it started OK but after ~40% download the download speed went down to ZERO

my conclusion till now - their server is either busy or very BAD one !!!

last time I installed CUDA 9.0. The download was extremely fast. It took about 20 seconds and was successfully installed. My internet speed is 100Mbps.
This time I need to download it again for my new machine and it took more than 7 hours to download. I don’t know why?
The shocking thing is after waiting for 7 hours when I tried to run it. I got this message.
“gzip: stdin: unexpected end of file
Extraction failed.
Ensure there is enough space in /tmp and that the installation package is not corrupt
Signal caught, cleaning up”
Can anyone help?