Looking for Cuda Toolkit 12.3 to download

I have been trying to download CUDA Toolkit 12.3.0 from this link:

or earlier version:

But I have not been able to open the site link to download. Not reachable.
Can someone please help pointing to the right place for download?

the latest download link is always at https://www.nvidia.com/getcuda

I get this download error once I get to the link:

Hmmm… can’t reach this page

It looks like the webpage at https://developer.download.nvidia.com/compute/cuda/12.3.0/local_installers/cuda_12.3.0_545.84_windows.exe might be having issues, or it may have moved permanently to a new web address.


This is when I click on the Base Installer 3.1GB download link highlighted in red below.

I don’t have any trouble downloading it. The problem may be with your internet service provider. I probably won’t be able to offer further suggestions.

I have used my default spectrum, google and cloudflare DNS’s
Could not open it.

I can download this as well. Check your Anti-virus, maybe this is blocking access.

I have tried with anti-virus off, on windows 10, windows 11 on different machines with different browsers, and on a google chrome on a chrome OS. All failed on my network through the very general Spectrum Internet that supplies most of US, with different DNS. All failed. I have no problem downloading everything else on the internet including exe files. It seems there is a source issue.

Are you guys able to download from external networks, i.e. not from internal nVidia ? Or you only tried it within your company nvidia network with the link.

I am using my home network from a different city.

Make sure your account is not capped out. I had an issue with my provider at one time when downloading a large file. Turned out I was over my data limit.

There is of course no cap. I can download a hundred terabyte no problem.

I figured it out. It is my global Adguard Home.

Thank you all. You can delete this thread.