Failed BOOT with AMD R7 5800H + NVIDIA GTX1650 Ubuntu 20.04.1 kernel-5.8.0 Lenovo Xiaoxin Pro16

Dear developers,

I am experiencing trouble with a mixture of AMD CPU (and its integrated Graphics) and NVIDIA discrete graphic cards. Since this combo is new on mobile PCs, I could not find enough resources to solve it.

Problem:
In the post-installation first-time boot, after selecting boot into ubuntu, I stuck with the Lenovo Xiaoxin logo

.
At this point, sticking in a USB gives a beep unique to the Ubuntu system. But I cannot access any tty.

Boot again with advanced options for ubuntu, still with kernel 5.8.0, I could access the shell. Here, I ran ubuntu-drivers autoinstall, which installed nvidia-driver-460-server. The installation succeeded with nvidia-smi correctly displaying my graphic card info. Reboot, stuck at Lenovo Xiaoxin logo again.

With more digging, I followed amd ryzen 5 mobile nvidia gtx 1050 login loop ubuntu 18.04, still to no avail.

P.S. The Ubuntu20.04 installation runs like butter, the only tiny suspicious logs are included in the photos below.

I apologize for not including a system-generated report, I will try it when I have time. For the time being, I would really appreciate any suggestion on commands/tweaks I could try to make it work.

Thank you! And looking forward to your reply.

I attach the aforementioned suspicious logs here. (It allows 1 media file per post, sorry)

You’ll need a newer kernel. 5.11.13+.
Also you need the amdgpu firmware files from:
https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/tree/amdgpu
get the green_sardine* files and put them into /lib/firmware/amdgpu.

1 Like

Or just install Ubuntu 21.04 which comes with correct kernel and firmware ootb.

1 Like

Thank you very much, it worked.