Failed to attach: Sequence contains no matching element

Hi all,

I’m using the latest Android Codeworks SDK and I’m having trouble attaching the debugger to my Nexus 7 running Android 5.1.1.

It simply says “Failed to attach: Sequence contains no matching element” - I can’t find anything specific about the error message on the forums or the net and wondered if there’s any other files I can check to find out more specific information regarding the error?


Let me know if you need any more information.

I’ve flashed stock 5.1.1 and re-locked the boot loader, now the debugger will attach however, it seems like no symbols are loaded and whenever I add a breakpoint it says that the breakpoint will never be hit because the module is not loaded. If I call abort() then the debugger will catch it however as suspected there are no symbols.

This always used to work for me until I got the latest Codeworks. Any help would be appreciated + any suggestions for logging information.


Hi Ghost Ban,

“Failed to attach: Sequence contains no matching element” is met when you use android sdk build-tools and platform-tools rc build. Is it like your case? We are working on this issue now.

Breakpoint can’t be hit.
Could you check if the module is loaded with symbols? You can see it via Debugger>Windows>Modules.


It doesn’t seem like the module is loaded at all let alone with symbols, if I deploy to my Samsung Galaxy S6 the module is loaded with symbols.

Does my Nexus 7 need to be rooted/unlocked boot loader?


Hi Maddius,

What are the versions Nsight Tegara and Nexus 7 OS Image?
Could you send me your log %APPDATA%C:\Users\test\AppData\Roaming\NVIDIA Corporation\Nsight Tegra\Logs\Nsight Tegra.log?


Nsight Tegra Version: 3.3.15329.2064
Nexus 7 OS Image: Android 5.1.1 (LMY47V)
Kernel Version: 3.1.10-gf5d7b8b

I will message you the log privately.

There doesn’t seem to be a way to upload a text file either here in private message… could I email them to you?

Hi Maddius,
Yes, you can email them to me and I have send you a private message.


Victor mentions this issue will be resolved in a future release if anybody else has similar issues!



I’m on Nsight Tegra Version 3.3.16047.9615 and I still have no symbols loading on my device, should this have been fixed with this release?

I’d really appreciate any help here as it makes debugging impossible on this device!


So… this just randomly started working, I made some changes to my project setup and that seems to have somehow loaded that module, the things I can think of that I did:

  • Uninstalled the App completely
  • Changed from not having any Java code to having a single Java class that extends NativeActivity
  • I used the AVD to emulate my physical device and deployed to the emu, not sure if that somehow invalidated something

And not a lot else to be honest…

So… yeah, not much help for anybody else with this but, that’s all I can remember doing.

Hi Maddius,

No symbols loading on the device is that due to .so is stripped on the device. non-tripped is loaded in gdb on the host side.

Could you send me the log to help us to figure out what’s wrong there?



is the “Failed to attach: Sequence contains no matching element” issue still a work in progress? Using CodeWorks for Android 1R4 (Nsight Tegra VS Edition 3.3) I get that error message with a Shield Tablet K1 (non-rooted) running Android 6.0.1. The same occurs with Samsung Google Nexus 10 (non-rooted) running Android 5.1. I have tried with two different PCs, both running Windows 10 and Visual Studio 2015 Community Edition.

As far as I know, I’m not using the rc builds (release candidate?) of build-tools and platform-tools. I’m using build-tools version 24 and platform-tools version 24.0.1.

I can send log files if needed.

Thanks for any help.

hi Devenec,
Could you try reset VS2015 plugin state by the following command?
Devenv /UpdateConfiguration
Devenv /ClearCache


Hi Victor,

those commands didn’t help, I still get the same error.

Hi Devenec,
We are looking into this issue as your configuration win10+VS 2015 community edition.


I am also experiencing this problem.
I just bought nvidia shield TV 16GB and flashed latest NVIDIA SHIELD ANDROID TV Developer Only OS Image.
I have installed latest nvidia CodeWorks for Android 1R4u1 with Visual Studio 2015 community edition.
When I try to run my application I get the message “… Starting GDB server… Done. Starting GDB debugger… Error. Failed to attach: Sequence contains no matching element”.
I bought SHIELD TV to develop and its not working, please help!
Tristan Rybak

HI trybackzek and Devenc,

We failed to repro your issue Win10 VS2015 community edition + update3. Did you install VC++ component of VS 2015? VC++ component is not installed by default but Nsight Tegra requires it. You can rerun the installer to install it via Programming Languages>Visual C++.


I have Visual C++ installed, but under it I have only “Common Tools for Visual C++ 2015” installed. Is “Microsoft Foundation Classes for C++” required? I assume “Windows XP Support for C++” is not.

Hi Victor,
I am compiling my project (native game activity) with visual studio so I guess VC++ component is installed.
Can you tell me what “Failed to attach: Sequence contains no matching element” message mean? Maybe I could fix it myself if I knew what is the cause of it?