tadp 3.0r4 debugger issues

Anytime I attempt to launch with debugging or attempt to attach the debugger to my running process I get a Status of

“Fail to attach: Object reference net set to an instance of an object.”

from either the Java debugger or the GDB debugger. Is there a known issues with this version? 3.0r3 worked for me.

hi timeisaparallax,
Is there any blank space in your project file path? The blank space in path could cause this.

victor

Thanks for getting back to me Victor,

Unfortunately I do not have any spaces in the path to my vcxproj files. The only related thing I can think of that might be relevant is that I don’t have my vcxproj and sln files all relative to each other like they are defaulted to when you use the project wizard. Mine is something like

C:\project\a.vcxproj
C:\project\samples\demo1\b.vcxproj
c:\project\samples\demo1\c.sln

Any chance that might have something to do with it?

Cheers,
-Bert

Hi Bert,

Can you send me the logs from the %AppData%\NVIDIA Corporation\Nsight Tegra\Logs? I’ll need the most recent one, or, even better, close VS, delete the logs, open it again and do one session of attaching to capture the issue in the logs.

I’ll send you my email in a PM.

I have the same error. If I’m just debugging my app - all ok. But there are no symbols loaded for external dependies. If I’m adding path to external libs to “Additional Library Symbols Directories” then I see that info was successfully loaded but error “Failed to attach: Object reference not set to an instance of an object.” appears. I can send the most recent log file.
upd:
These external libraries are built with “-Wl,–soname=”.

I’ll send you my email in a PM. The log file is very welcome, thank you.

Update: Bert’s issue is device-specific and is related to GDB. Unfortunately, at the moment we cannot guarantee that Nsight Tegra will work correctly on devices with API level 16 (Android 4.1). Older Nsight Tegra versions seem to work (they were bundled with an older GDB).

Here’s the issue in the Android bug tracker: https://code.google.com/p/android/issues/detail?id=68623

To anyone having the similar issues: while we’re working on a solution, please try unchecking the Android Exceptions -> C++ Exception in the Exceptions window or clicking the Reset All button there. The GDB we’re currently using fails to enable handling thrown exception on some devices.

Hey

I’m having the same issue. I mainly develop on a Shield Tablet, and have not had an issue with that, but have now tried it on a S3 and I get the above error.

Resetting the exceptions didn’t fix the issue for me.

David.

Edit: I have tried it on a couple of devices on API 17 and I am not having the issue, so it seems that it is the API 16 issue you mentioned above.

I’m having the same issue after upgrading nSight_Tegra 3.2.15288.5934 from 3.1.15202.6244. :(

  • I have no blank in the my project file path.
  • I clicked the “Reset All” in the Android Exceptions.
  • I’ve tested with many API level (16, 17, 9, 22), but all has same issue for me. :(

I’m using Nexus 7 with Lolipop.

Is there any further workarounds?

We’ve fixed some of the issues that manifested in such error messages in the upcoming release. For example, it currently fails to attach if the project is built with ndk-build or another non-Nsight Tegra build system, and the primary architecture in the APK is ARMv5TE (armeabi). Building for ARMv7A (armeabi-v7a) will work around this issue.