VS 2013, Tegra 3.0: "Unable to start program" error when trying to debug

I have installed the latest AndroidWorks with Nsight Tegra 3.0 using Visual Studio 2013 on an existing project and it is not able to find a debugger.

I created a test project that was all native and I’m able to debug it just fine and I’m also able to debug the samples.

The problem is when I go to project properties and select the “Debugging” tab, no debugger shows up. If I do this for the projects that work, they have “Nsight Tegra Debugger” selected in the “Debugger to launch:” drop down. My project has nothing in that drop down.

The project is a fairly large internal game engine that had the “Tegra-Android” platform added through the configuration manager. I’ve tried quite a few things so far to make it look exactly like the test project in hopes that it would show the debugger but no luck so far. Any ideas?

Try to edit vcproj file manually. I don’t know what exactly is wrong there, but it is there I think.

I have tried hand editing the XML in the vcxproj and made it look almost identical to the test project that was working.

Although we have quite a few other platforms in there. I suppose I could remove everything else that’s not related to Tegra from the XML just to see if I can get it working and work backwards to find what is causing it.

Lol, so turns out all I needed to do was delete the vcxproj.user file and that worked. I had deleted the .suo file but I guess I never did the .user as well.