Fails to run deepstream-test1 example in docker container

Please provide complete information as applicable to your setup.

• Hardware Platform (Jetson / GPU) AGX Xavier
• DeepStream Version 6.0
• JetPack Version (valid for Jetson only) 4.6
• TensorRT Version (jetpack 4.6 default)
• NVIDIA GPU Driver Version (valid for GPU only) (jetpack 4.6 default)
• Issue Type( questions, new requirements, bugs) why do I get internal data stream error when running examples on 264 streams?

I’m able to run the sample scripts eg /samples/configs/deepstream-app:
deepstreamp-app -c source12_12080p_dec…txt works fine.

But when I try to run python_apps or compile deepsteram test-1 app, it fails.

• How to reproduce the issue ? (This is for bugs. Including which sample app is using, the configuration files content, the command line used and other details for reproducing)
Running a docker container:

xhost +
docker run -it --net=host --runtime nvidia
-w /opt/nvidia/deepstream/deepstream-6.0
-v /tmp/.X11-unix/:/tmp/.X11-unix
-v /usr/src/:/opt/nvidia/deepstream/deepstream-6.0/repos
–mount type=bind,source=/var/output,target=/var/output

when the docker is running then install the following packages:

$ apt-get install libgstreamer1.0-dev libgstreamer-plugins-base1.0-dev -y

Then the deepstream-script apps works eg.

cd /opt/nvidia/deepstream/deepstream-6.0/samples/configs/deepstream-app
deepstream-app -c source12_1080p_dec_infer-resnet_tracker_tiled_display_fp16_tx2.txt

(the script is using the following stream: …/…/streams/sample_1080p_h264.mp4 as source)


$ cd /opt/nvidia/deepstream/deepstream-6.0/sources/apps/sample_apps/deepstream-test1#
$ make CUDA_VER=10.2
$ ./deepstream-test1-app …/…/…/…/samples/streams/sample_1080p_h264.mp4

generates the error:

0:00:03.809349028 722 0x55ab9a84f0 INFO nvinfer gstnvinfer.cpp:638:gst_nvinfer_logger: NvDsInferContext[UID 1]: Info from NvDsInferContextImpl::generateBackendContext() <nvdsinfer_context_impl.cpp:2004> [UID = 1]: Use deserialized engine model: /opt/nvidia/deepstream/deepstream-6.0/samples/models/Primary_Detector/resnet10.caffemodel_b1_gpu0_int8.engine
0:00:03.817216372 722 0x55ab9a84f0 INFO nvinfer gstnvinfer_impl.cpp:313:notifyLoadModelStatus: [UID 1]: Load new model:dstest1_pgie_config.txt sucessfully
ERROR from element h264-parser: Internal data stream error.
Error details: gstbaseparse.c(3611): gst_base_parse_loop (): /GstPipeline:dstest1-pipeline/GstH264Parse:h264-parser:
streaming stopped, reason not-negotiated (-4)
Returned, stopping playback
Deleting pipeline

I get the same error when installing the python bindings and trying to run test1 app.
I’ve tried to run it on the *.mjpeg stream instead but then everything hangs.

why is this happening?

best regards/
Daniel Grafström


• Requirement details( This is for new requirement. Including the module name-for which plugin or for which sample application, the function description)

Test1 sample only accept H264 elementary stream.

I do not understand your answer.
The sample-video I referred to is h264 encoded in a mp4 container if as mentioned in the filename.
(DeepStream Python Test Error: python3 h264_elementary_stream)

In test1 sample, the pipeline only parse h264 file and decode, and other components. for mp4 file, it will need demux then parse h264 file.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.