Fedora 38 nvidia driver 530.41.03

Updated different DELL Hardware (Workstation, Notebook) with NVIDIA cards (RTX4000, P3200) to driver version 530.41.03. All computers have the same problem now:

  • Black screen after reboot, no login screen available (mouse is working), but typing the password (blind) loggs me in
  • Two displays are shown in the configuration (the build in display and a ghost display “unknown 24”)

How can I fix this behavior?

Thanks and best regards,

Hello @thomas.zellner and welcome to the NVIDIA developer forums.

Did you disable the GUI AND unload all NVIDIA kernel modules before installing the new driver AND reboot immediately?

You might still have incompatible driver “pieces” in your system.

Boot into console mode, unload any and all NVIDIA modules, re-install and reboot.

If that does not help, after module unloading, purge all NVIDIA drivers (I don’t know how to do that on Fedora though), reboot into console and re-install.

Hope that will work for you!

Hi Markus,
Thanks for your answer! I did some further tests today. I have the same issue with a new from scratch installed Fedora (the system has never seen an NVIDIA driver before). I am using the rpmfusion drivers.
Best regards,

On that fresh install with the NVIDIA driver installed, can you call sudo nvidia-bug-report.sh and attach the result file here?

What was your previous driver version and does the system work normally if you downgrade again?


nvidia-bug-report.log.gz (70.2 KB)

I have the same problem, same driver version, same repository (rpmfusion) and same linux distro, I tested it on Fedora Workstation (gnome env) and Fedora spin with KDE (it is even worse there)

We are in the process of migrating our Fedora workstations from version 36 to 38. The driver version 530.41.03 works properly with Fedora 36, so we don’t have an older version to test for Fedora 38.

nvidia-bug-report.log (455.7 KB)

@xSylla hello and welcome to the NVIDIA developer forums.

Some of your issues might be attributed to the usage of Wayland. At the moment we still recommend to stay with XOrg instead. This message in your log is one inidicator:

giu 08 22:05:50 xsylla-ms7c56.Home kernel: [drm:__nv_drm_gem_nvkms_map [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00002b00] Failed to map NvKmsKapiMemory 0x000000009ec234af

But in general the log info looks rather sparse and the only possible issue I see is that the driver taints the kernel, which might cause problems.

But since my Fedora expertise is rather limited, I think I try and pull in some more eyes and move this topic to the Linux category.

We have been using Wayland for a long time. We never saw such behavior with Fedora 36 in conjunction with NVIDIA and Wayland.

Unfortunately same behavior with 535.54.03 😥

NVIDIA does a pretty bad job supporting newer GNU/Linux technologies and they brag their drivers are more tested than AMD’s…
Rant done, simpledrm is enabled by default on fedora kernels and causes your extra monitor (use initcall_blacklist=simpledrm_platform_driver_init) to disable it. I believe they said nvidia is supporting this now, but it doesn’t seem the case, at least not with newest drivers.
Also, if using wayland, make sure nvidia-drm.modeset=1 is set


With the kernel command line “initcall_blacklist=simpledrm_platform_driver_init” the ghost display is gone (Thanks mmbossoni). But a second physical display wont work (is not recognized). Whether with or without the kernel command line. It’s a nightmare 😭 Same Hardware with Fedora 36 and nvidia 530.41.03 is working without any problem… Fedora 38 and nvidia 535.54.03 no chance.

What kernel version are you using?

I have a laptop (Acer Predator Helios 300 from 2019) with a GTX 1660 Ti, and it works fine with kernel 6.3.12. I’m using the Nvidia driver from rpmfusion, version 535.86.05.

However, under kernel 6.4.6 and 6.4.7, the laptop’s built-in display is always black. I can plug an external monitor into the HDMI port and that works correctly. Gnome and xrandr do not recognize the built-in display.

I just tried adding initcall_blacklist=simpledrm_platform_driver_init and nvidia-drm.modeset=1 to the kernel command line. Everything worked without them on kernel 6.3.12. They didn’t help with kernel 6.4.7.

Can you confirm that? Are there still problems with the new drivers now?

There was a driver update that cleared up this problem.