Flash JetPack OS to a Jetson Nano TX2 board (recovery mode)

Hi everybody!

We bought the Jetson TX2 NX module for our Jetson Nano to reuse the Jetson Nano carrier board from the developer kit, because de gpio for both boards are compatible.

We’ve seen that this board contains a 16Gb eMMc instead of having an external micro SD.

To flash the JetPack OS on this board we’ve tried to configure the board into the recovery mode and use the SDK manager software to flash the OS.

We are having problems when we try to configure the recovery mode because de SDK manager doesn’t detect the recovery mode. The message we get is ‘The board is not into recovery mode’.

We’ve followed the steps shown below:

  1. Connect the GND and FC REC gpios using a jumper
  2. Download the OS JetPack files from SDK manager
  3. Configure the SDK manager flashing mode to Manual
  4. Connect the board to the host machine by USB. Moreover, we’ve connected the power supply. (At this point, the SDK manager detects correctly the board)
  5. Remove the jumper from GND and FC REC

By doing the previous steps, we’re not able to configure the recovery mode as we always have the same error message (‘The board is not into recovery mode’)

Does anybody know how to set the TX2 NX board into recovery mode? Are we following the correct steps?

Thanks for the attention.

Is the host PC a VM? If so, then this causes such a problem. If not, check the following:

  • The “recovery” pins work like a shift key on a keyboard. If recovery is on during power up or power reset, then you get recovery mode. Holding the recovery pin at any other time or for longer than this has no effect.
  • Recovery mode itself does not alter a Jetson. All it does is boot it to be a simple USB device, and the driver package on the host PC understands that device.
  • If you have started a Jetson with recovery pin on, then remove the recovery pin short. Then, on your host PC, monitor “dmesg --follow”. Watch which log lines might show up as you plug in the Jetson’s USB to the host PC.
  • Actual USB will show all NVIDIA USB devices via “lsusb -d '0955:'”. What does this show? This is how JetPack/SDK Manager will decide what is connected.

First of all, thanks for your response.

Our host PC is not a VM.

When we execute the command ‘dmesg --follow’ we get the information of the USB (product, manufacturer) so, the host PC detects the USB.

What we get when we try “lsusb -d ‘0955:’” is the following information: Bus 001 Device 009: ID 0955:7f21 NVidia Corp.

The problem is when we try to flash the JetPack OS to the board. When we configure the flash process in Manual mode and we start it, the error we found is that the board is in a bad state and we have to configure the recovery mode manually. We’ve tried the same steps, but we allways have the same error and we are not able to flash the TX2 NX board.

Finally, we have found the problem.

I have seen that the board selected in the SDK manager should be the Jetson Nano developer kit (in our case) not the TX2 module.

We have changed the configuration and now we can flash the OS JetPack to the board.

Yes, manufacturer ID 0955 would show for all Jetsons, but device ID 7f21 is specific to a Nano. The lsusb which would look specifically for the Nano is:
lsusb -d '0955:7f21

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.