Flash Jetson AGX Xavier 16GB/32GB: Failed to execute commands with GenericInstaller

Hi,

trying to flash the OS image is failing.
I tried the following with no help:

  • uninstalling the host/agx software using sdkmanager, deleting the download directories, and reinstalling
  • running flash.sh manually

help will be appreciated.
This is the log I get in sdkmanager:
NV_L4T_FLASH_XAVIER_WITH_OS_IMAGE_COMP.log (35.3 KB)

2 Likes

This seems like a hardware issue, as it is reproduced with flash.sh it is not an sdk manager issue.

Please check the log from serial console and share with us.

https://elinux.org/Jetson/General_debug

Thank you for the response.

This is what I get using minicom -D /dev/ttyUSB3 -8 -b 115200 upon power on, connected to the micro usb port on the devboard. I havent seen anything printed to the terminal during the actual flashing process.

[0000.085] W> RATCHET: MB1 binary ratchet value 4 is too large than ratchet lev.
[0000.093] I> MB1 (prd-version: 1.5.1.3-t194-41334769-d2a21c57)
[0000.098] I> Boot-mode: Coldboot
[0000.101] I> Chip revision : A02P
[0000.104] I> Bootrom patch version : 15 (correctly patched)
[0000.110] I> ATE fuse revision : 0x200
[0000.113] I> Ram repair fuse : 0x0
[0000.116] I> Ram Code : 0x2
[0000.119] I> rst_source : 0x0
[0000.121] I> rst_level : 0x0
[0000.125] I> Boot-device: eMMC
[0000.140] I> sdmmc DDR50 mode
[0000.144] W> No valid slot number is found in scratch register
[0000.149] W> Return default slot: _a                                           
[0000.153] I> Active Boot chain : 0                                             
[0000.156] I> Boot-device: eMMC                                                 
[0000.159] W> MB1_PLATFORM_CONFIG: device prod data is empty in MB1 BCT.        
[0000.167] I> Temperature = 21000                                               
[0000.170] W> Skipping boost for clk: BPMP_CPU_NIC                              
[0000.175] W> Skipping boost for clk: BPMP_APB                                  
[0000.179] W> Skipping boost for clk: AXI_CBB                                   
[0000.183] W> Skipping boost for clk: AON_CPU_NIC                               
[0000.187] W> Skipping boost for clk: CAN1                                      
[0000.191] W> Skipping boost for clk: CAN2                                      
[0000.195] I> Boot-device: eMMC                                                 
[0000.198] I> Boot-device: eMMC                                                 
[0000.207] I> Sdmmc: HS400 mode enabled                                         
[0000.212] I> ECC region[0]: Start:0x0, End:0x0                                 
[0000.216] I> ECC region[1]: Start:0x0, End:0x0                                 
[0000.220] I> ECC region[2]: Start:0x0, End:0x0                                 
[0000.224] I> ECC region[3]: Start:0x0, End:0x0                                 
[0000.228] I> ECC region[4]: Start:0x0, End:0x0                                 
[0000.232] I> Non-ECC region[0]: Start:0x80000000, End:0x100000000              
[0000.238] I> Non-ECC region[1]: Start:0x0, End:0x0                             
[0000.242] I> Non-ECC region[2]: Start:0x0, End:0x0                             
[0000.247] I> Non-ECC region[3]: Start:0x0, End:0x0                             
[0000.251] I> Non-ECC region[4]: Start:0x0, End:0x0                             
[0000.257] E> FAILED: Thermal config                                            
[0000.264] E> FAILED: MEMIO rail config                                         
[0000.282] E> Task 50 failed (err: 0x7979061c)                                  
[0000.286] E> Top caller module: ALIASCHECKER, error module: ALIASCHECKER, reas6
[0000.295] I> MB1(1.5.1.3-t194-41334769-d2a21c57) BIT boot status dump :        
00000000000111111111101111111111111111111111001111100000000000000000000000000000
[0000.325] I> Reset to recovery mode  

Hi,

Do you have other Xavier device to verify your host setup is correct?

we have some on order but I imagine it’ll take time.
This board and host operated correctly, I was able to use this host to flash the devkit and have been able to run inference successfully on the jetson.
The problem started the day after I ran inference. I left the board to compile some stuff (OpenCV inside the
l4t-pytorch:r32.4.4-pth1.6-py3 docker container) I came back after an hour or so and tried to wake it from sleep but it stopped responding.

It sounds like a hardware issue. Let’s wait for other Xavier to confirm your software there are correct.

1 Like