Flash Jetson AGX Xavier error on version 34.1

I tried to load the Jetson OS using the SDK Manager to the Xavier Industrial P2888 through the USB-C on the custom carrier board with the Xavier in recovery mode but I got error.

image

I attached the error log from the uart and the terminal messages from the SDK Manager
nvidia_faile_sdkmanager_text (5.0 KB)
Error log message07_12_2022.txt (2.4 KB)
so you could see the error is on the eeprom. I have a eeprom in the custom carrier board but it is blank. Is that cause the flash error on the SDK Manager ? How to bypass eeprom check in order to continue the code flashing?

Thanks

Joe Lam

We also run the command “sudo ./flash.sh jetson-agx-xavier-devkit mmcblk0p1” after the SDK Manager failed and we got the attached message at the uart log

Error log message after flash command.txt (5.7 KB)

If this is not official carrier board, then you need to modify the cvb eeprom read size to 0 in Linux_for_Tegra/bootloader/t186ref/BCT.

BTW, if this is agxi, then your board config should use that one which has “industrial” in the file name.

Hi WayneWWW. Thanks for the support and now I could flashed successfully. It seems run fine after the code flashed but after I reset the Xavier then following message appear from the uart log
Error log message_07_13_2022_reset after flashed.txt (6.2 KB)
We tried to set the eeprom read size to 0 on both cvb and cvm and it still not working. What will cause this problem and why it works fine right after the Xavier flashed but failed after an reset?

Hi,

I only say cvb. I didn’t say cvm. You cannot set cvm eeprom read size to 0.

Hi WayneWWW,

I still see the following error after I reset the board from first boot

[0000.025] W> RATCHET: MB1 binary ratchet value 4 is larger than ratchet level 2 from HW fuses.
[0000.033] I> MB1 (prd-version: 2.2.0.0-t194-41334769-3540ffaa)
[0000.039] I> Boot-mode: Coldboot
[0000.042] I> Platform: Silicon
[0000.044] I> Chip revision : A02P
[0000.047] I> Bootrom patch version : 15 (correctly patched)
[0000.053] I> ATE fuse revision : 0x200
[0000.056] I> Ram repair fuse : 0x0
[0000.059] I> Ram Code : 0x1
[0000.062] I> rst_source: 0x0, rst_level: 0x0
[0000.067] I> Boot-device: QSPI (instance: 0)
[0000.070] I> Qspi flash params source = brbct
[0000.075] I> Qspi using bpmp-dma
[0000.078] I> Qspi clock source : pllp
[0000.081] I> QSPI Flash Size = 64 MB
[0000.084] I> Qspi initialized successfully
[0000.088] I> Boot chain mechanism: A/B
[0000.092] I> Current Boot-Chain Slot: 0
[0000.095] W> No valid slot number is found in scratch register
[0000.101] W> Return default slot: _a
[0000.104] I> Qspi flash params source = brbct
[0000.110] W> PROD_CONFIG: device prod data is empty in MB1 BCT.
[0000.117] I> Temperature = 31000
[0000.120] W> Skipping boost for clk: BPMP_CPU_NIC
[0000.125] W> Skipping boost for clk: BPMP_APB
[0000.129] W> Skipping boost for clk: AXI_CBB
[0000.133] W> Skipping boost for clk: AON_CPU_NIC
[0000.137] W> Skipping boost for clk: CAN1
[0000.141] W> Skipping boost for clk: CAN2
[0000.145] I> Boot-device: QSPI (instance: 0)
[0000.149] I> Qspi flash params source = mb1bct
[0000.153] I> Qspi using bpmp-dma
[0000.156] I> Qspi clock source : pllc_out0
[0000.160] I> Qspi reinitialized
[0000.163] I> Qspi flash params source = mb1bct
[0000.169] I> Qspi flash params source = mb1bct
[0000.173] I> ECC region[0]: Start:0x80000000, End:0x780000000
[0000.180] W> Thermal config not found in BCT
[0000.188] W> MEMIO rail config not found in BCT
[0000.204] I> DRAM ECC Scrub Mode: staged
[0000.262] I> Qspi flash params source = mb1bct
[0000.272] I> Qspi flash params source = mb1bct
[0000.285] I> Qspi flash params source = mb1bct
[0000.352] I> Qspi flash params source = mb1bct
[0000.361] I> Qspi flash params source = mb1bct
[0000.369] W> Platform config not found in BCT
[0000.396] I> Qspi flash params source = mb1bct
[0000.408] I> MB1 done

▒▒▒▒main enter
SPE VERSION #: R01.00.18 Created: Jan 29 2021 @ 14:18:27
HW Function test
Start Scheduler.
in late init
▒▒
[0000.417] I> Welcome to MB2(TBoot-BPMP) (version: default.t194-mobile-f46b9673)
[0000.418] I> DMA Heap @ [0x526fa000 - 0x52ffa000]
[0000.418] I> Default Heap @ [0xd486400 - 0xd48a400]
[0000.419] E> DEVICE_PROD: Invalid value data = 70030000, size = 0.
[0000.425] W> device prod register failed
[0000.429] I> Boot_device: QSPI_FLASH instance: 0
[0000.433] I> qspi flash-0 params source = boot args
[0000.439] I> QSPI-0l initialized successfully
[0000.442] I> sdmmc-3 params source = safe params
[0000.762] I> sdmmc DDR50 mode
[0000.768] I> Found 53 partitions in QSPI_FLASH (instance 0)
[0000.769] W> Cannot find any partition table for 00000003
[0000.770] > PARTITION_MANAGER: Failed to publish partition.
[0000.775] I> Found 12 partitions in SDMMC_USER (instance 3)
[0000.775] I> Staged scrubbing
[0000.985] W> No valid slot number is found in scratch register
[0000.985] W> Return default slot: _a
[0000.986] I> Active Boot chain : 0
[0001.051] I> Relocating BR-BCT
[0001.053] > DEVICE_PROD: device prod is not initialized.
[0001.078] I> Skip reading CVB eeprom BoardID
[0001.103] I> Relocating OP-TEE dtb from: 0x6bfff0f0 to 0x70060000, size: 703
[0001.104] I> [0] START: 0x80000000, SIZE: 0x2c000000
[0001.105] I> [1] START: 0xac200000, SIZE: 0x69ba00000
[0001.105] I> dram_block larger than 80000000
[0001.107] I> Setting NS memory ranges to OP-TEE dtb finished.
[0001.154] I> EKB detected (length: 0x410) @ VA:0x52709400
[0001.156] I> Setting EKB blob info to OPTEE dtb finished.
▒▒NOTICE: BL31: v2.5(release):ef8af0b99
NOTICE: BL31: Built : 20:57:59, May 16 2022
I/TC:
▒▒
bpmp: init
bpmp: tag is 128431eec76692047e1ac1ebc0392266
sku_dt_init: not sku 0x00
sku_dt_init: not sku 0x98
▒▒I/TC: Non-secure external DT found
▒▒clk_early initialized
mail_early initialized
fuse initialized
hwwdt initialized
t194_ec_get_ec_list: found 45 ecs
ec initialized
vmon_setup_monitors: found 3 monitors
vmon initialized
adc initialized
fmon_populate_monitors: found 73 monitors
fmon initialized
mc initialized
reset initialized
nvhs initialized
uphy_early initialized
emc_early initialized
392 clocks registered
clk initialized
io_dpd initialized
thermal initialized
thermal_mrq initialized
i2c initialized
vrmon_dt_init: vrmon node not found
vrmon_chk_boot_state: found 0 rail monitors
vrmon initialized
regulator initialized
avfs_clk_platform initialized
soctherm initialized
aotag initialized
powergate initialized
▒▒I/TC: OP-TEE version: 6f444acf (gcc version 9.3.0 (Buildroot 2020.08)) #2 Tue May 17 04:00:18 UTC 2022 aarch64
I/TC: Pr▒▒dvs initialized
▒▒i▒▒pm initialized
▒▒ma▒▒suspend initialized
▒▒ry ▒▒pg_late initialized
▒▒CP▒▒pg_mrq_init initialized
strap initialized
▒▒U▒▒nvl initialized
▒▒ initializin▒▒emc initialized
emc_mrq initialized
▒▒g
▒▒clk_dt initialized
tj_init initialized
uphy_dt initialized
uphy_mrq initialized
uphy initialized
ec_swd_poll_start: 281 reg polling start w period 47 ms
ec_late initialized
hwwdt_late initialized
reset_mrq initialized
ec_mrq initialized
fmon_mrq initialized
clk_mrq initialized
avfs_mrq initialized
mail_mrq initialized
i2c_mrq initialized
tag_mrq initialized
console_mrq initialized
mrq initialized
clk_sync_fmon_post initialized
clk_dt_late initialized
noc_late initialized
pm_post initialized
dbells initialized
dmce initialized
cvc initialized
avfs_clk_mach_post initialized
avfs_clk_platform_post initialized
cvc_late initialized
regulator_post initialized
rm initialized
console_late initialized
clk_dt_post initialized
mc_reg initialized
pg_post initialized
profile initialized
fuse_late initialized
extras_post initialized
entering main console loop
] bpmp: init complete
▒▒I/TC: Primary CPU switching to normal world boot
▒▒
Jetson UEFI firmware (version r34.1-975eef6 built on 2022-05-16T20:58:45-07:00)
tion in EL3.PIDR 0x80000000: exception reason=0 syndrome=ndle0000c0
x30Unhandled Exception in EL3.
x30

What is this error and what cause this error? Or should I close this topic and reopen another one since this is no longer a code flash problem?

Thanks
Joe Lam

Please file a new topic. Also, put your log into a text file and attach. It is not reasonable to directly post a hundreds lines of log into comment.

OK and thanks for your
support.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.