AGX Xavier error during flashing

Hi,
I am reopening this topic: https://forums.developer.nvidia.com/t/agx-xavier-error-during-flashing/163603.
Unfortunately I do not have access to the system all the time.

I am currently trying again to flash my AGX Xavier board. Unfortunately the script is not executed successfully. This is the command I am running:
sudo ./flash.sh jetson-xavier mmcblk0p1

This is what I have found in the logs:
[ 8.5118 ] Sending bootloader and pre-requisite binaries
[ 8.5126 ] tegrarcm_v2 --download blob blob.bin
[ 8.5132 ] Applet version 01.00.0000
[ 8.5304 ] Sending blob
[ 8.5306 ] […] 100%
[ 9.4222 ]
[ 9.4244 ] tegrarcm_v2 --boot recovery
[ 9.4263 ] Applet version 01.00.0000
[ 9.4460 ]
[ 10.4494 ] tegrarcm_v2 --isapplet
[ 10.7194 ]
[ 10.7216 ] tegrarcm_v2 --ismb2
[ 10.7416 ]
[ 10.7847 ] tegradevflash_v2 --iscpubl
[ 10.7867 ] Bootloader version 01.00.0000
[ 10.9528 ] Bootloader version 01.00.0000
[ 10.9535 ]
[ 10.9536 ] Retrieving storage infomation
[ 10.9556 ] tegrarcm_v2 --oem platformdetails storage storage_info.bin
[ 10.9576 ] Applet is not running on device. Continue with Bootloader
[ 10.9790 ]
[ 10.9811 ] tegradevflash_v2 --oem platformdetails storage storage_info.bin
[ 10.9830 ] Bootloader version 01.00.0000
[ 10.9984 ] Saved platform info in storage_info.bin
[ 10.9996 ]
[ 10.9998 ] Flashing the device
[ 11.0016 ] tegraparser_v2 --storageinfo storage_info.bin --generategpt --pt flash.xml.bin
[ 11.0045 ]
[ 11.0067 ] tegradevflash_v2 --pt flash.xml.bin --create
[ 11.0084 ] Bootloader version 01.00.0000
[ 11.0104 ] Erasing sdmmc_boot: 3 … [Done]
[ 12.1115 ] Writing partition secondary_gpt with gpt_secondary_0_3.bin
[ 12.1121 ] […] 100%

[ 12.1942 ] Erasing sdmmc_user: 3 … [Done]
[ 12.2158 ] Writing partition master_boot_record with mbr_1_3.bin
[ 12.2164 ] […] 100%
[ 12.2175 ] Writing partition primary_gpt with gpt_primary_1_3.bin
[ 12.2182 ] […] 100%
[ 12.2198 ] 000000000d0d0001: o initialize partition table from GPT.
[ 12.2213 ]
[ 12.2213 ]
Error: Return value 1
Command tegradevflash_v2 --pt flash.xml.bin --create
Failed flashing t186ref.

Here is the complete log from the serial consol during flash:
[0541.759] C> XUSBF: comp_code went out of sequence. Expected 1 instead of 223.
???
[0020.110] W> RATCHET: MB1 binary ratchet value 4 is too large than ratchet level 1 from HW fuses.
[0020.119] I> MB1 (prd-version: 1.5.1.0-t194-41334769-59d8a47d)
[0020.124] I> Boot-mode: Platform RCM
[0020.127] I> Chip revision : A02
[0020.131] I> Bootrom patch version : 7 (correctly patched)
[0020.136] I> ATE fuse revision : 0x200
[0020.139] I> Ram repair fuse : 0x0
[0020.142] I> Ram Code : 0x0
[0020.145] I> rst_source : 0x0
[0020.147] I> rst_level : 0x0
[0020.151] I> USB configuration success
[0022.247] I> mb2 image downloaded
[0022.256] I> Recovery boot mode 0
[0022.260] I> Boot-device: eMMC
[0022.264] I> UPHY full init done
[0022.269] I> MB1 done

[0022.274] W> Profiler not initialized
[0022.277] I> Welcome to MB2(TBoot-BPMP) Applet (version: 00.00.2018.32-mobile-e0a450b9)
[0022.285] W> Profiler not initialized
[0022.289] I> DMA Heap @ [0x40020000 - 0x40065800]
[0022.293] I> Default Heap @ [0xd486400 - 0xd48a400]
[0022.298] W> Profiler not initialized
[0022.302] W> Profiler not initialized
[0022.305] E> DEVICE_PROD: Invalid value data = 0, size = 0.
[0022.310] W> device prod register failed
[0022.314] W> Profiler not initialized
[0022.510] I> sdmmc DDR50 mode
[0022.514] I> No supported QSPI flash found
[0022.518] E> QSPI Flash: Insufficient flash size (0 MB)
[0022.523] I> QSPI Flash is not present.
[0022.574] E> Link startup dme_set failed
[0022.578] E> UFS initialization failed
[0022.582] I> UFS is not present
[0022.585] W> Profiler not initialized
[0022.594] I> Found 15 partitions in SDMMC_BOOT (instance 3)
[0022.602] W> Cannot find any partition table for 00010003
[0022.607] W> Profiler not initialized
[0022.610] W> Profiler not initialized
[0022.614] W> Profiler not initialized
[0022.617] I> Entering 3p server
[0022.621] I> USB configuration success
[0023.392] I> Populate eeprom info
[0023.395] I> Populate eeprom info for module cvm
[0023.483] I> Rebooting : reboot-recovery

[002

???
[0211.236] W> RATCHET: MB1 binary ratchet value 4 is too large than ratchet level 1 from HW fuses.
[0211.244] I> MB1 (prd-version: 1.5.1.0-t194-41334769-59d8a47d)
[0211.250] I> Boot-mode: RCM
[0211.252] I> Chip revision : A02
[0211.255] I> Bootrom patch version : 7 (correctly patched)
[0211.261] I> ATE fuse revision : 0x200
[0211.264] I> Ram repair fuse : 0x0
[0211.267] I> Ram Code : 0x0
[0211.270] I> rst_source : 0xb
[0211.272] I> rst_level : 0x1
[0211.276] I> USB configuration success
[0213.276] I> bct_bootrom image downloaded
[0213.287] E> MB1_PLATFORM_CONFIG: device prod data is empty in MB1 BCT.
[0213.293] E> MB1_PLATFORM_CONFIG: Failed to initialize device prod.
[0213.301] I> Temperature = 35500
[0213.304] W> Skipping boost for clk: BPMP_CPU_NIC
[0213.308] W> Skipping boost for clk: BPMP_APB
[0213.312] W> Skipping boost for clk: AXI_CBB
[0213.316] W> Skipping boost for clk: AON_CPU_NIC
[0213.320] W> Skipping boost for clk: CAN1
[0213.324] W> Skipping boost for clk: CAN2
[0213.328] I> Boot-device: eMMC
[0213.331] I> Boot-device: eMMC
[0213.334] I> bct_mb1 image downloaded
[0213.344] I> ECC region[0]: Start:0x0, End:0x0
[0213.349] I> ECC region[1]: Start:0x0, End:0x0
[0213.353] I> ECC region[2]: Start:0x0, End:0x0
[0213.357] I> ECC region[3]: Start:0x0, End:0x0
[0213.361] I> ECC region[4]: Start:0x0, End:0x0
[0213.365] I> Non-ECC region[0]: Start:0x80000000, End:0x100000000
[0213.371] I> Non-ECC region[1]: Start:0x0, End:0x0
[0213.375] I> Non-ECC region[2]: Start:0x0, End:0x0
[0213.380] I> Non-ECC region[3]: Start:0x0, End:0x0
[0213.384] I> Non-ECC region[4]: Start:0x0, End:0x0
[0213.390] W> MB1_PLATFORM_CONFIG: Rail ID 9 not found in pmic rail config table.
[0213.397] E> FAILED: Thermal config
[0213.401] W> DEVICE_PROD: device prod is not initialized.
[0213.410] W> MB1_PLATFORM_CONFIG: Rail ID 7 not found in pmic rail config table.
[0213.417] E> FAILED: MEMIO rail config
[0213.429] I> scrub mode: full dram
[0213.432] E> FUSE: Failed to verify ECID.
[0213.436] I> bct_mem image downloaded
[0214.765] I> blob image downloaded
[0214.791] I> Recovery boot mode 0
[0214.830] W> MB1_PLATFORM_CONFIG: Rail ID 8 not found in pmic rail config table.
[0214.862] I> MB1 done

???main enter
SPE VERSION #: R01.00.14 Created: Sep 19 2018 @ 11:03:21
HW Function test
Start Scheduler.
in late init
???
[0214.872] I> Welcome to MB2(TBoot-BPMP) Recovery (version: 00.00.2018.32-mobile-d7f8bdb0)
[0214.873] I> DMA Heap @ [0x526fa000 - 0x52ffa000]
[0214.873] I> Default Heap @ [0xd486400 - 0xd48a400]
[0214.875] E> DEVICE_PROD: Invalid value data = 70020000, size = 0.
[0214.880] W> device prod register failed
[0214.885] I> parsing oem signed section of bpmp-fw header done
[0214.893] I> bpmp-fw binary copied from blob
[0214.895] I> oem authentication of bpmp-fw header done
[0214.899] I> bpmp-fw: Authentication init Done
[0214.903] I> parsing oem signed section of cpubl header done
[0214.910] I> cpubl binary copied from blob
[0214.913] I> bpmp-fw: Authentication Finalize Done
[0214.918] I> oem authentication of cpubl header done
[0214.922] I> cpubl: Authentication init Done
[0214.926] I> parsing oem signed section of tos header done
[0214.933] I> tos binary copied from blob
[0214.936] I> Relocating BR-BCT
[0214.939] I> cpubl: Authentication Finalize Done
[0214.943] I> oem authentication of tos header done
[0214.947] I> tos: Authentication init Done
[0214.951] I> parsing oem signed section of bpmp-fw-dtb header done
[0214.959] I> bpmp-fw-dtb binary copied from blob
[0214.962] I> tos: Authentication Finalize Done
[0214.968] I> oem authentication of bpmp-fw-dtb header done
[0214.972] I> bpmp-fw-dtb: Authentication init Done
[0214.976] I> parsing oem signed section of cpubl-dtb header done
[0214.983] I> cpubl-dtb binary copied from blob
[0214.986] I> bpmp-fw-dtb: Authentication Finalize Done
[0215.150] I> oem authentication of cpubl-dtb header done
[0215.150] I> cpubl-dtb: Authentication init Done
[0215.151] I> parsing oem signed section of eks header done
[0215.152] I> eks binary copied from blob
[0215.152] I> cpubl-dtb: Authentication Finalize Done
[0215.153] I> oem authentication of eks header done
[0215.154] I> eks: Authentication init Done
[0215.157] I> eks: Authentication Finalize Done
[0215.161] I> EKB detected (length: 0x410) @ VA:0x526fb600
???NOTICE: BL31: v1.3(release):a28d87f09
NOTICE: BL31: Built : 13:29:53, Nov 5 2019
ipc-unittest-main: 1519: Welcome to IPC unittest!!!
ipc-unittest-main: 1531: waiting forever
ipc-unittest-srv: 329: Init unittest services!!!
keystore-demo: 141: Hello world from keystore-demo app
keystore-demo: 207: main: EKB contents match expected value
exit called, thread 0xffffffffea88ed58, name trusty_app_2_7d18fc60-e9fc-11e8
platform_bootstrap_epilog: trusty bootstrap complete
???

welcome to lk
calling constructors
initializing heap
creating bootstrap completion thread
top of bootstrap2()
initializing platform
bpmp: platform_init
tag is c1b4e372932429f2737cf722e1219e71
tag_show initialized
dt initialized
mail initialized
chipid initialized
fuse initialized
sku initialized
speedo initialized
ec_get_ec_list: found 45 ecs
ec initialized
ec_mrq initialized
vmon_populate_monitors: found 3 monitors
vmon initialized
adc initialized
fmon_populate_monitors: found 73 monitors
fmon initialized
fmon_mrq initialized
reset initialized
nvhs initialized
392 clocks registered
clk_mrq_init: mrq handler registered
clk initialized
nvlink initialized
io_dpd initialized
io_dpd initialized
thermal initialized
i2c5 controller initialized
initialized i2c mrq handling
i2c initialized
regulator initialized
avfs_clk_platform initialized
soctherm initialized
aotag initialized
powergate initialized
dvs initialized
pm initialized
pg_late initialized
strap initialized
tag initialized
emc initialized
clk_dt initialized
avfs_ccplex_platform initialized
tj_max: dt node not found
tj_init initialized
/uphy is not enabled status = disabled
uphy_dt initialized
uphy initialized
safereg initialized
mrq initialized
???
[0215.628] I> Welcome to TBoot-CPU Recovery
???fmon_post initialized
???[0215.628] I> Heap: [0xa5000000 … 0xaa000000
[0215.631] I> CPU: Nvidia Carmel
[0215.634] I> CPU: MIDR: 0x4e0f0040, MPIDR: 0x80000000
[0215.639] I> chip revision : A02
[0215.642] I> Boot-device: eMMC
[0215.645] I> Boot_device: SDMMC_BOOT instance: 3
???clk_dt_late initialized
machine_check initialized
pm_post initialized
dbells initialized
avfs_clk_platform_post initialized
dmce initialized
cvc initialized
ccplex_avfs_hw_init: nafll_cluster0: not monitored
ccplex_avfs_hw_init: nafll_cluster1: not monitored
ccplex_avfs_hw_init: nafll_cluster2: not monitored
ccplex_avfs_hw_init: nafll_cluster3: not monitored
avfs_clk_mach_post initialized
regulator_post initialized
rm initialized
sc7_diag initialized
thermal_test initialized
serial_late initialized
clk_post initialized
clk_dt_post initialized
mc_reg initialized
pg_post initialized
dyn_modules initialized
sku_debugfs initialized
speedo_debugfs initialized
adc_debugfs initialized
clk_debugfs initialized
emc_debugfs initialized
dvs_debugfs initialized
fmon_debugfs initialized
vmon_debugfs initialized
pg_debugfs initialized
profile_fs initialized
debugfs_cons initialized
mail_fs initialized
profile initialized
cvc_debugfs initialized
dmce_debugfs initialized
ec_debugfs initialized
rm_debugfs initialized
soctherm_debug initialized
gr_reader initialized
mods initialized
dt_fs initialized
debugfs_mrq initialized
debug_mrq initialized
debug_safereg initialized
initializing target
calling apps_init()
starting app shell
entering main console loop
] ???[0216.060] I> sdmmc-3 params source = boot args
[0216.060] I> sdmmc bdev is already initialized
[0216.061] I> sdmmc-3 params source = boot args
[0216.063] I> Found 15 partitions in SDMMC_BOOT (instance 3)
[0216.065] W> Cannot find any partition table for 00010003
[0216.066] I> Recovery boot_type: 0
[0216.066] I> Entering 3p server
[0216.066] I> USB configuration success
[0216.175] I> Populate storage info
[0216.199] I> Erasing device 0: 3
[0217.280] I> Writing device 0: 3.
[0217.360] I> Found 15 partitions in SDMMC_BOOT (instance 3)
[0217.361] I> Erasing device 1: 3
[0217.383] I> Writing device 1: 3.
[0217.385] I> Writing device 1: 3.
[0217.387] W> Cannot find any partition table for 00010003
[0217.387] E> NV3P_SERVER: Failed to initialize partition table from GPT.

Thanks again

Hello,

Then could you reply my previous questions?

  1. Please read this page and dump the log from serial console during flash.
    https://elinux.org/Jetson/General_debug

-> Don’t need to check this page anymore. Your log is sufficient.

  1. Why do you mention sdcard? Only NX and Nano has sdcard image. Other platforms don’t have it.
  2. Are you sure this is not a 8gb Xavier?

Hi WayneWWW

Of course. Sorry. I forgot that.

2.) This was a mistake of me. I thought this board is using a sd-card

3.) I am not 100% sure about this. Today in the morning I tried to flash the board assuming it is a 8gb xavier.
This is the command I used:
./flash.sh jetson-xavier-8gb mmcblk0p1
Unfortunately the flashing procedure stuck at the following point:
[ 8.5306 ] […] 100%
[ 9.4222 ]
[ 9.4244 ] tegrarcm_v2 --boot recovery
[ 9.4263 ] Applet version 01.00.0000
[ 9.4460 ]
[ 10.4494 ] tegrarcm_v2 --isapplet

Here is the serial log dump:
[0212.819] I> Welcome to MB2(TBoot-BPMP) Recovery (version: 00.00.2018.32-mobile-d7f8bdb0)
[0212.819] I> DMA Heap @ [0x526fa000 - 0x52ffa000]
[0212.820] I> Default Heap @ [0xd486400 - 0xd48a400]
[0212.821] E> DEVICE_PROD: Invalid value data = 70020000, size = 0.
[0212.827] W> device prod register failed
[0212.832] I> parsing oem signed section of bpmp-fw header done
[0212.839] I> bpmp-fw binary copied from blob
[0212.841] I> oem authentication of bpmp-fw header done
[0212.846] I> bpmp-fw: Authentication init Done
[0212.850] I> parsing oem signed section of cpubl header done
[0212.856] I> cpubl binary copied from blob
[0212.859] I> bpmp-fw: Authentication Finalize Done
[0212.864] I> oem authentication of cpubl header done
[0212.869] I> cpubl: Authentication init Done
[0212.873] I> parsing oem signed section of tos header done
[0212.879] I> tos binary copied from blob
[0212.882] I> Relocating BR-BCT
[0212.885] I> cpubl: Authentication Finalize Done
[0212.890] I> oem authentication of tos header done
[0212.894] I> tos: Authentication init Done
[0212.898] I> parsing oem signed section of bpmp-fw-dtb header done
[0212.905] I> bpmp-fw-dtb binary copied from blob
[0212.909] I> tos: Authentication Finalize Done
[0212.914] I> oem authentication of bpmp-fw-dtb header done
[0212.918] I> bpmp-fw-dtb: Authentication init Done
[0212.923] I> parsing oem signed section of cpubl-dtb header done
[0212.930] I> cpubl-dtb binary copied from blob
[0212.933] I> bpmp-fw-dtb: Authentication Finalize Done
[0213.031] I> oem authentication of cpubl-dtb header done
[0213.031] I> cpubl-dtb: Authentication init Done
[0213.032] I> parsing oem signed section of eks header done
[0213.033] I> eks binary copied from blob
[0213.033] I> cpubl-dtb: Authentication Finalize Done
[0213.034] I> oem authentication of eks header done
[0213.035] I> eks: Authentication init Done
[0213.038] I> eks: Authentication Finalize Done
[0213.042] I> EKB detected (length: 0x410) @ VA:0x526fb600
��NOTICE: BL31: v1.3(release):a28d87f09
NOTICE: BL31: Built : 13:29:53, Nov 5 2019
ipc-unittest-main: 1519: Welcome to IPC unittest!!!
ipc-unittest-main: 1531: waiting forever
ipc-unittest-srv: 329: Init unittest services!!!
keystore-demo: 141: Hello world from keystore-demo app
keystore-demo: 207: main: EKB contents match expected value
exit called, thread 0xffffffffea88ed58, name trusty_app_2_7d18fc60-e9fc-11e8
platform_bootstrap_epilog: trusty bootstrap complete
��

welcome to lk
calling constructors
initializing heap
creating bootstrap completion thread
top of bootstrap2()
initializing platform
bpmp: platform_init
tag is c1b4e372932429f2737cf722e1219e71
tag_show initialized
dt initialized
mail initialized
chipid initialized
fuse initialized
sku_init: not sku de
sku_init: not sku 00
sku_init: sku 0xd0 not found in /sku/te860m-a2
sku_init: compatible SKUs:
sku_init: 0xde
sku_init: 0x00
FATAL: cannot continue
HALT: spinning forever…

Thank you very much

Ok, then I guess your device is not 8gb xavier.

You can try to do some test with below

  1. Try different ubuntu host
  2. Try different usb cable
  3. Try different Xavier modules (if you have them).

Your current log seems indicating the “Linux_for_Tegra” has something incomplete.
Thus, reinstall it might also worth trying.

I have another Xavier which is working fine. I will try to flash it with my current setup.
I will give you a feedback ASAP
Thanks

If you cannot even flash another xavier with current setup, then issue is on the host side.

I successfully flashed the other xavier with the same setup…


So I think the problem is the board, or?
Thanks

1 Like

Could you compare the sticker on the module and see if they are different?

Also, what is the jetpack version you are using?

You can also try other jetpack version.

If none of them can flash this board, then please RMA it.

I have three Xaviers, but I do not know which on is the broken one.
Does this help you?

I am using Jetpack 4.2.3. Tegra_linux version is 32.2.3

Could you try to use latest jetpack4.4.1 to prevent any possible bug?

BTW, I need to sticker on the module itself. The pictures you posted are from the devkit box?

I will try it next week. There I will have some spare time. Thanks
The only difference I can find on both boards is the P/N (hopefully product number)
On the working one: 945-82972-0045-000
On the broken one: 945-82972-0005-000
Or do you also need the serial number?
And yes, the stickers are from the devkit box.
Thanks

Same error with jetpack 4.4.1
[ 10.9452 ] tegradevflash_v2 --pt flash.xml.bin --create
[ 10.9462 ] Bootloader version 01.00.0000
[ 10.9661 ] Erasing sdmmc_boot: 3 … [Done]
[ 12.0612 ] Writing partition secondary_gpt with gpt_secondary_0_3.bin
[ 12.0625 ] […] 100%

[ 12.1746 ] Erasing sdmmc_user: 3 … [Done]
[ 12.6674 ] Writing partition master_boot_record with mbr_1_3.bin
[ 12.6687 ] […] 100%
[ 12.6702 ] Writing partition primary_gpt with gpt_primary_1_3.bin
[ 12.6762 ] […] 100%
[ 12.6774 ] 000000000d0d0001: o initialize partition table from GPT.
[ 12.6907 ]
[ 12.6908 ]
Error: Return value 1
Command tegradevflash_v2 --pt flash.xml.bin --create
Failed flashing t186ref.

Then please RMA it.

Thank you very much for your support

1 Like