Jetson xavier agx jetpack error

Hi, I’m using jetson xavier agx and trying to flash using jetpack.

I got an install error and I don’t know why I got this error messeges.

I attached my log file.

SDKM_logs_JetPack_5.0.2_(rev.1) (65.8 KB)

Is this a custom carrier board or nv developer kit?

It’s jetson xavier agx developer kit.

12:00:34.442 - info: NV_L4T_FLASH_XAVIER_WITH_OS_IMAGE_COMP@JETSON_AGX_XAVIER_TARGETS: [ 10.1800 ] 000000003626050d: E> NV3P_SERVER: Could not read eeprom for module cvb.

According to your log, eeprom on the carrier board is failed to get read. I don’t think it is normal software error.

Are you still able to flash your board with jp4.x? If so, could you flash with it and share me the boot up log with jp4?

I cannot select Jetpack 4.x version. Only 5.x version is available

Do you have ubuntu 18.04 x86_64 host on your side that can test?

I only have 20.04 version so I cannot test. Is there any other ways?

I tried on 18.04 and have same errors.
I attached logfile. (197.3 KB)

Could you check the uart log with below setup and check the log “after” your start the flash process?

I tried following steps but nothing comes up on minicom.

Also, I’ve tried $ sudo ./ jetson-xavier mmcblk0p1 command and I could boot up jetson.
However, no libraries are installed.


Are you saying that you can flash the board with

Yes, I can install L4T and able to boot up. However, I need CUDA but no libraries available via jetpack is not installed.


Then it is separate issue.

First, you don’t need to select “flash OS” in sdkmanager anymore. That will try to reflash your board again and we don’t need it. Select to install SDK only. That will include CUDA.

If it fails, export the SDKM log again

Second, try to use other tool like picocom instead of minicom. Also, open the console before you power on the device in case there are log printed but you miss it.

I skipped flashing and tried to install SDK components and “Default ip is not avaliable. Please make sure the default ip is shown in ip addr, or use a customer ip instead.” message appeared.
I tried to use ip address that jetson board is using with wifi connection, “Cannot connect to the device via SSH. Check the user name and password, and make sure that SSH service is running on the device.” message appeared.
What ip address should I use?


First, every “IP” only exists after your device’s network activity is ON. However, it sounds like your board totally not able to boot up now. Could you confirm this first or not? That is why I asked you get the console to work fine first.

Second, by default, if you connect the flash usb port between your host and jetson, then there would be a network IP based on USB port.
But again, this port is only alive after your device is really booting into ubuntu.

I can boot jetson and if it’s booted, I can connect ssh but in recovery mode, I can’t.

I can see Nvidia Corp. by $ lsusb but I cannot find any usb device on /dev/ttyUSB*.

I think that’s why I could not open console with minicom.


Installing SDK does not need the board in recovery mode…

Am I doing right for installing SDK?

If I boot up the board, I got these messages.


I don’t see you post any message…

On the screenshot, nvidia SDK manager said I should connect board on recovery mode to install jetson SDK components.