Flash to NVME fail on NX 8GB module

Dear NVidia,

I just got my new custom carrier board returned from factory, and tried to flash jet linux image into a 256GB nvme SSD on it, using SDK manager 2.0.

Below is my host machine environment and SDK version.

The flash procedure failed with numerous “flash: tar: Write checkpoint” errors.

The flash logs are attached, for 2 independent sessions of flash.

Not sure how to proceed. Any suggestions?

The SSD is a brand new one, not formatted. Do i have to format it before perform the flashing?

Thank you.

SDKM_logs_JetPack_5.1.2_Linux_for_Jetson_Orin_NX_modules_2023-10-24_22-46-47.zip (184.4 KB)
SDKM_logs_JetPack_5.1.2_Linux_for_Jetson_Orin_NX_modules_2023-10-24_23-32-29.zip (406.0 KB)


Please don’t use SDK Manager for flashing custom boards. It’s only meant to be used with DevKits.
If the custom board is made my yourself, then you should know how to apply all customization in device tree, pinmux, etc, to fit your need.

Thank you for the reply.

if SDK manager can not be used to flash custom boards, then what tool should I use?

You should use flashing scripts included in our BSP + flashing config file customized for your carrier board, which contains correct device trees, BCT, pinmux, etc.

sudo ./tools/kernel_flash/l4t_initrd_flash.sh --external-device nvme0n1p1 \
  -c tools/kernel_flash/flash_l4t_external.xml -p "-c bootloader/t186ref/cfg/flash_t234_qspi.xml" \
  --showlogs --network usb0 jetson-orin-nano-devkit internal

Replace jetson-orin-nano-devkit with your own one.

Thanks for the swift reply. I will try that out.

do I need to format the SSD first before flashing?

We’d recommend doing it.

So here is the results of my test of flashing through initrd script.

sudo ./tools/kernel_flash/l4t_initrd_flash.sh --external-device nvme0n1p1   -c tools/kernel_flash/flash_l4t_external.xml -p "-c bootloader/t186ref/cfg/flash_t234_qspi.xml"   --showlogs --network usb0 jetson-orin-nano-devkit-nvme internal

As pin assignment of my custom board is very close to devkit, and nvme is the only storage onboard, so jetson-orin-nano-devkit-nvme config is used directly here.

The procedure ends up in “waiting for target to boot up …” and timeout.
The host log and NX module log are attached.
From NX side log seems it is busy waiting for EEPROM, which is not present on my custom board. How do i disable it?

host_log.txt (270.4 KB)

NX_flash_log.txt (32.1 KB)

You should do this:

OK it seems working now. I need to continue with further tests on it.

Thank your for the help and quick response.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.