Flashing QNX onto Jetson TK1

Hi, I’m having trouble flashing QNX onto a Jetson TK1.

Firstly, I’m trying to use vibrante-vcm30t124-qnx-V3Q-23.16.01-5757763.zip. Is that the correct? I’m a bit worried because the hardware inside the documentation here looks different, but I don’t know the alternative.

I’ve tried flashing that version using:

./bootburn.sh -q -S 56 -b 1859 -Z zlib

When I try on ubuntu 14.04, then it fails with:

Waiting for USB device. This may take up to 100 seconds…
Can’t find USB device for ADB commnunication
Tool OutPut:

I also tried a vm with ubuntu 12.04 (as the docs suggested this), but this has the problem that bootburn just hangs forever:

m30t124-qnx-V3Q/utils/scripts/bootburn$ ./bootburn.sh -q -S 56 -b 1859 -Z zlib
Booting to retrieve BCT & Chip Info

I have verified on both machines that the board is in recovery with lsusb | grep -i nvidia.

Any suggestions?

I know nothing about QNX, but unless bootburn.sh is designed to work with a recovery mode Jetson, you’ll probably need to adapt to using L4T flash.sh with the QNX root file system sample instead.

According to the documentation, bootburn is designed to work with a recovery mode Jetson.

Is there a URL where instructions and files can be downloaded?

hold recovery button, press reset; release recovery button; the run the flash command. robin