Flashing the Jetson TX1

Hi everyone

I recently acquired a Jetpack TX1 and after to install Jetpack L4T it works fine, but in an attempt to install some drivers for ROS the gnome terminal and the command line stopped working, after a long time to try to solving it I think that the best solution is flashing the device. Searching in this forum I found that it can be solved with the same Jetpack L4T installation with the option ‘flash OS’. On the other way I have another TX1 thats works fine.

My question is about the step 8 on the following guide:

http://docs.nvidia.com/jetpack-l4t/index.html#developertools/mobile/jetpack/jetpack_l4t/2.1/jetpack_l4t_install.htm

Where can I get the IP adress of the device?, and on the other side… Could I clone the system of the second TX1 and after install it on the first?. What should I do?

Thanks a lot for your answers!

You can use Xterm as an alternative terminal to figure out why gnome terminal is broken. The likely scenario is that the /etc/default/locale file got messed up during the ROS install.

From within Xterm, if you attempt to run gnome-terminal and get status 8 back, that’s the culprit. Older versions of the ROS instructions setup the locale, which Ubuntu 16.04 apparently takes exception to. If you can get the locale correct again, everything should work correctly. Since you have another TX1, you can probably just copy the locale settings from there. Make sure to reboot the machine after copying for the change to take effect.

Instructions for cloning are available on the Jetson TX1 Wiki:

http://elinux.org/Jetson/TX1_Cloning

As I recall, there are three different terminal programs on the TX1, Terminal, Xterm and UXTerm. If you can get one of those to work, you should be able to get the IP address using ifconfig.

Address is usually available in the log of the DHCP server. If that is a router, you should have a web interface to see what it assigned. If that is a Linux host, then dmesg should note an assignment. It is also possible JetPack may have done more network setup to use a name like “tegra-ubuntu”, but I can’t verify that.

You can clone a Jetson for install on a different Jetson. Usually you just clone and install the root partition, but you could clone and install any partition you’re interested in (usually other partitions are not needed for cloning, and only in some cases would cloning a non-root partition help). Clone is described here:
https://devtalk.nvidia.com/default/topic/898999/jetson-tx1/tx1-r23-1-new-flash-structure-how-to-clone-/post/4784149/#4784149

Restoring from a clone involves using the flash.sh program normally, except adding the “-r” option to re-use system.img (and of course you need to replace “bootloader/system.img” with your cloned version). Since the clone is not compressed/sparse, clone takes a bit longer for copy to the Jetson (but some time is also saved because you don’t build system.img). If you originally flashed to the Jetson from which the clone was created using “sudo ./flash.sh -S 14580MiB jetson-tx1 mmcblk0p1”, then you’d use the same command but add the “-r”, “sudo ./flash.sh -r -S 14580MiB jetson-tx1 mmcblk0p1”.

Thanks both for your answers!, I tried with the locale settings from the second TX1 and the gnome-terminal starts to working again :)!. Likewise I will clone the second TX1 partition with your tutorials to have a backup for future troubles.

Thanks again both for your answers!

I have flashed my NVidia Jetson TX1 using SDK Manager. I have followed each and every step of as prescribed in SDK.
As all the libraries are installed during the during flashing the TX1 kit, then why we need to re-install the libraries.
Or is there some other possible way to use those libraries.

Lab5@tegra-ubuntu:~$ python3
Python 3.6.8 (default, Oct  7 2019, 12:59:55) 
[GCC 8.3.0] on linux
Type "help", "copyright", "credits" or "license" for more information.
>>> import keras
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
ModuleNotFoundError: No module named 'keras'
>>> import tensorflow
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
ModuleNotFoundError: No module named 'tensorflow'
>>> import matplotlib
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
ModuleNotFoundError: No module named 'matplotlib'
>>>

As we can see that none of the libraries are available. Please help me to understand the same as soon as possible.