Forspoken - Really bad performance no matter the settings or the driver version

Mozo, that is why I specifically said driver 535.43.09 only that one has the fix to make Implement VK_NV_device_generated_commands_compute by HansKristian-Work · Pull Request #1639 · HansKristian-Work/vkd3d-proton · GitHub run on nvidia.
Not 525.125.06, which you use.

  • Fixes:
  • Bug fixes for VK_NV_device_generated_commands_compute
  • Correctly clear fragment shading rate attachments with LOAD_OP_CLEAR
  • Fix potential device lost with vkCmdBlitImage when fragment shading rate is used
  • Correctly restore pipeline static state if previously overwritten by dynamic state set calls and pipeline is rebound
  • Fix dual-source blending when output is written to an array variable
  • Fix VK_KHR_cooperative_matrix bug with variable pointer shared memory CTS tests

EDIT: if I had forspoken I would’ve just tested it, but I don’t have that game. If you can install that specific driver use VKD3D_CONFIG=skip_driver_workarounds to allow execution of the specific extension on VKD3D then it should work as intended. But note 535 will not allow you to play starfield.

Yes, you’re right - I only tested Starfield with VKD3D_CONFIG=skip_driver_workarounds and 535.43.09. I’ll try Forespoken later for here is 3 AM and I’m falling asleep.

1 Like

The game doesn’t run with 535.43.09, VKD3D_CONFIG=skip_driver_workarounds and Linux Kernel 6.4.12. The game does run with 535.43.09, VKD3D_CONFIG=skip_driver_workarounds and and Linux Kernel 6.5.1-273-tkg-cfs but there’s no difference at all - the perf is terrible.

1 Like

Thanks for the update! Perhaps it’s best to be checked yet again - as the suspicion from VKD3D devs was that extension was causing the issue. Now that it’s resolved then the issue most likely lies somewhere else(for both Halo Infinite/Forspoken, Starfield is mixed results so far to confirm).

1 Like

I don’t know, it’s a complete mess…

535.43.10 doesn’t change anything.

535.43.11 doesn’t change anything either. Here it’s running at full speed on AMD:

Hi All,
Issue is not root caused yet, but I can see update on the bug on regular basis, team is actively working on it to fix it.
Thanks for being patient.

1 Like

Thank you Amrits!

Just saying - 545.23.06 doesn’t fix the problem.

545.29.02 - same terrible perf.

535.43.16 no dice.

Does passing SteamDeck=0 %command% makes any changes to perf situation? Yes, it can add a flickering but mainly i want to know if it makes any perf diff.

As it seems to be forced as =1 to everyone currently, to mitigate some issues but maybe has some side effects on NV setups.

https://steamdb.info/app/891390/info/

1 Like

No, it makes no difference. I tried it a long time ago.

1 Like

Returning with GeForce RTX 4090 Gaming X Trio 24G. There’s no difference, the game perf is extremely low.

Just to share an update that this issue has been worked upon actively.
We are performing internal testings at the moment.

2 Likes

Thank you!

Thanks for the update!

In case anyone wonders, I tried with the new 550.40.07 beta drivers, no change.

This is being worked upon and will update once fix will be integrated into release driver.

2 Likes