G-SYNC monitors when used together with non-G-SYNC monitors

Hi,

Acording to Changelog the 349 series of drivers added support for setups with Mixed G-SYNC and regular Monitors.

But I find myself unable to get it to work.

I have two Monitors (Acer XB280HK, 4k G-SYNC and Iiyama PL2481H) in one X-Screen, TwinView. Both attached to a GTX 680.

Is this somehow the wrong setup? does it need some xorg.conf settings or whatever?

I’m not an expert but you’re likely running into maximum virtual size issues. Would need to play around with it personally to try and work around that, but here’s an example:

Not sure what Nvidia’s actual limit is, but I don’t think it’s related to gsync as you’re having issues even loading the desktop, right?

Also probably want to post your Xorg logs and other stuff per the bug reporting guidelines or at least review them to see if they show your errors.

Nono everything is fine but the G-SYNC.

The Screen runs fine at 60hz 4k + the second one on 60hz 1080p no problem what soever with that.
And G-SYNC is working when I disable the second monitor in the driver.

And the Changelog makes it sound like it should just work now. The problem is that I’m unable to find any Documentation about this, so I’m just guessing how to get it to work.

Hm. I’ll have to try adding a second monitor to my system and see if I can get it working. Just curious, are you also affected by this issue when you have gsync on? My post got a good number of views but no replies and I don’t have any other systems to test it on.

https://devtalk.nvidia.com/default/topic/829054/linux/gsync-black-flickering-on-fps-drops/

No I haven’t got that issue. When Frames drop really low (<15) flickering of the back light becomes perceptible but no black frames as you describe it.

Also I Ran the bug report script:
Once with only the GSYNC Monitor Active, with GSYNC working, Confirmed via visual indicator and monitor display (fps bar) in Dota 2: https://mega.co.nz/#!0wMxXTqL!8wnF88FDIFw-8Z5M-CF1XuO_52alf7Ogi-vW9Op-hTo

And once with both Monitors active, GSYNC not working, confirmed via visual indicator and monitor display in Dota 2: https://mega.co.nz/#!R8k0hRqb!Bh4HwhHXSbG1ifbHZj0yIrlg2izfd4FHDjJF2NgSWvA

Is your application covering the entire desktop, or just one of the two monitors? G-SYNC requires the application to be able to flip, which requires that its window be unoccluded, unredirected, and covering the entire desktop.

You can try enabling the G-SYNC indicator in the OpenGL tab of nvidia-settings. If the word “NORMAL” is drawn, then the application is flipping but not using G-SYNC. If nothing is printed, then the application is falling back to blitting and G-SYNC won’t work.

Ah now it makes sense. All applications are indeed only on one Monitor and seem to fall back to blitting, even when I disable the compositor.

Well that makes the setup pretty much useless when using monitors that are not practical for spanning one app across them (i.e. different sizes). Ok back to disabling the second monitor for gaming then…

Hello,

I have two monitors, one with the G-Sync support, one without. Sometime ago, when the driver updated to 349.16, I found out that G-Sync started to work perfectly with my setup, even with Sync to VBlank disabled (I always had it disabled). I did have to use a compositor (compton) for it to work though, without the compositor the monitor’s built-in menu reports no G-Sync and the nvidia-settings G-Sync indicator isn’t shown, even when launching games like Half-Life in full-screen.

Today I updated to 352.09 only to find out that G-Sync stopped working. Without the compositor the same problem occurs (no indicator, nothing), with the compositor the indicator does show but always prints NORMAL (and the monitor’s menu shows that G-Sync is inactive as well). I tried disabling the second monitor through the nvidia-settings and nothing changed. I tried messing with the vsync settings in the compositor and the game (Half-Life), enabling or disabling Sync to VBlank, starting the game in fullscreen mode (with one or two monitors active), nothing helps.

When I’m using two monitors I’m running them as a single X screen. I’m using the Awesome WM.

So why did it break and is there a way to fix it?

Thanks in advance.