GeForce GTX 1080 Ti installed driver not working as expected

01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GP107 [GeForce GTX 1050 Ti] [10de:1c82] (rev a1)
01:00.1 Audio device [0403]: NVIDIA Corporation GP107GL High Definition Audio Controller [10de:0fb9] (rev a1)

I just successfully installed the nVidia drivers:
System: Dell XPS 8930
nVidia Card: GeForce GTX 1050 Ti (details, above)
OS: Fedora 28 (w latest updates)

NVIDIA-Linux-x86_64-410.73.run

I am not getting correct corresponding sounds from within Settings–>Sound–Test Speakers (button)

My receiver says it’s receiving 8 x 48k (~= 7.1)

HDMI video output at 1080p works seemingly perfectly
The display works @ 1080p but the display settings doesn’t show dual monitors when I am using a 2nd monitor. I use a 2nd monitor for troubleshooting by attaching the DVI out, kbd, mouse to my desktop display (275T), kbd, and mouse.

HDMI audio works in stereo, well.

HDMI audio in 5.1 or 7.1 doesn’t seem to have all the channels and the center channel is definitely not present–which is obvious when people are speaking and no voice can be heard.

Software
KODI is the primary software used on my HTPC
VLC - I have also tested using VLC with the same results

Audio & Video Connections:
DVI out --> PC display Samgsung SyncMaster 275T (for setup purposes only)
HDMI out --> DVDO iScan Duo --> (projector & audio receiver)

  • note the iScan Duo works with other HDMI inputs and various sources from stereo through 7.1 to the projector and audio receiver.

I read the “read this 1st” and am providing the following attachments:

a-2-chnl-sound.png - shows the work-around where I can get sound but only Digital Stereo seems working correctly
b-7.1-chnl-sound.png - picture of settings with 7.1 selected
c-7.1-chnl-sound-TestSpeakers.png - picture after pressing the “Test Speakers” button from picture “b”
d-Displays.png - Displays settings. I believe this should show 2 displays. You can see it shows the correct buttons for multiple displays. For some reason it is not showing the 2 displays as it should.
nvidia-bug-report.log.gz
nvidia-installer.log - as FYI given the install completed, but just in case

b-7.1-chnl-sound.png
c-7.1-chnl-sound-TestSpeakers.png
a-2-chnl-sound.png
d-Displays.png
nvidia-installer.log (9.36 KB)
nvidia-bug-report.log.gz (1020 KB)

You probably connected the Samsung to your internal gpu, please connect it to the nvidia card and disable the onboard graphics.

XPS 8930 system specs page - https://www.dell.com/support/manuals/us/en/04/xps-8930-desktop/xps-8930-setup-and-specification/ports-and-connectors?guid=guid-881045b1-98e0-4e6d-a2bc-6478dc7ea6ce&lang=en-us

One HDMI 1.4 port for integrated graphics
One DisplayPort for integrated graphics

I had forgotten and had to verify–my system board has HDMI and DisplayPort.

I purchased the system, as-is (the nVidia 1080 Ti already installed).

I do have a question in to Dell to confirm my research but it appears there is no BIOS option to disable the video.

At the very least I can confirm I am only using the nVidia card outputs for HDMI and DVI and per my previous post the card is recognized and appears in settings.

Any ideas?

Ok, browsing the log a ‘GVE DVID Extender’ is detected at some time and the mode is set up for it:

[394855.203] (II) NVIDIA(0): Setting mode "HDMI-0: nvidia-auto-select @1920x1080 +0+0 {ViewPortIn=1920x1080, ViewPortOut=1920x1080+0+0}, DVI-D-0: 1920x1080 @1920x1080 +0+0 {ViewPortIn=1920x1080, ViewPortOut=1920x1080+0+0}"

Please install and start acpid and set

Option "ModeDebug" "true"

in the device section of your xorg.conf and provide a new nvidia-bug-report.log
Does the Samsung work when directly connected?

About your 7.1 Sound problem:
the capabilities of your iScan are reported as follows:

eld_valid		1
monitor_name		iScan Duo
   
connection_type		HDMI
eld_version		[0x2] CEA-861D or below
edid_version		[0x3] CEA-861-B, C or D
manufacture_id		0x5404
product_id		0x3145
port_id			0x200
support_hdcp		0
support_ai		0
audio_sync_delay	0
speakers		[0x2f] FL/FR LFE FC RL/RR FLC/FRC
sad_count		4
sad0_coding_type	[0x2] AC-3
sad0_channels		6
sad0_rates		[0xe0] 32000 44100 48000
sad0_max_bitrate	640000
sad1_coding_type	[0x7] DTS
sad1_channels		8
sad1_rates		[0x6e0] 32000 44100 48000 88200 96000
sad1_max_bitrate	1536000
sad2_coding_type	[0x6] AAC-LC
sad2_channels		8
sad2_rates		[0xe0] 32000 44100 48000
sad2_max_bitrate	1536000
sad3_coding_type	[0x1] LPCM
sad3_channels		2
sad3_rates		[0x1ee0] 32000 44100 48000 88200 96000 176400 192000
sad3_bits		[0x0]

_

Which means that in LPCM mode, which the system is using for sound, it only supports stereo (2 channels). Only for DTS and AAC-LC streams 7.1 (8 channels) are supported. So 7.1 will only work for material (video/audio) which contains the supported audio codec streams.

Hello, I have 2 gtx 1080 ti sli connected, but it seems ubuntu 16.04 lts just recognize one of them, what can I do? Tell me what information I need to publish for you to have more details and please tell me the command to obtain the information in question in my terminal. Thank you.

jping3d, please create a new thread, don’t hijack this. Then run nvidia-bug-report.sh as root and attach the resulting .gz file to your post. Hovering the mouse over an existing post of yours will reveal a paperclip icon.
https://devtalk.nvidia.com/default/topic/1043347/announcements/attaching-files-to-forum-topics-posts/

Hi generix!

1st, I’m sorry for the long delay. I’ve been working with nVidia support regarding an access (specifically authentication) problem that, for some strange reason, allows me auth and access to all of nVidia online except devtalk. Go figure. Although I have to admit in all my years working in the tech industry I was well-known for being the gremlin finder.

ACPID:

[root@theater ~]# dnf search acpid
Last metadata expiration check: 0:18:49 ago on Mon 17 Dec 2018 06:12:01 PM EST.
========================= Name Exactly Matched: acpid ==========================
acpid.x86_64 : ACPI Event Daemon
[root@theater ~]# dnf info acpid
Last metadata expiration check: 0:19:00 ago on Mon 17 Dec 2018 06:12:01 PM EST.
Installed Packages
Name         : acpid
Version      : 2.0.30
Release      : 1.fc28
Arch         : x86_64
Size         : 156 k
Source       : acpid-2.0.30-1.fc28.src.rpm
Repo         : @System
From repo    : updates
Summary      : ACPI Event Daemon
URL          : http://sourceforge.net/projects/acpid2/
License      : GPLv2+
Description  : acpid is a daemon that dispatches ACPI events to user-space programs.

ACPID was already was already installed when I checked, FYI.

I then made the requested 1-line addition to xorg.conf as follows:

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    Option         "true"
EndSection

Not being sure, I rebooted after making the suggested change to my xorg.conf.

Shortly after this post you will find my updated nvidia-bug-report.log with today’s date.

Audio:
I think I understand. I have questions and some thoughts:

Does this mean the little buttons in “Settings” (for each speaker) will or will not work when I’m set to 7.1? Per my initial post I was expecting the speaker test buttons in Settings to play a test tone (as they do on my other systems)–see the picture c-7.1-chnl-sound-TestSpeakers.png (linked in 1st post).

In Settings I manually change the output to stereo to get audio to work. Should I be providing you with an nvidia-bug-report for the settings changed to 7.1? I’m going to do that JIC so please look for the appropriately designated report.

I spoke with DVDO support (the iScan manufacturer) and I will note they have excellent support (from my experience to this point–and I’m picky about making comments like this). They said the iScan is expecting a bitstream which it’s not getting if it displays LPCM. I am going to follow-up with them with the additional information you provided and I will update you with their response.

Can you please point me to a test file? That way you will know I’m using something appropriate to verify.

Also, can you help me understand how it works? Specifically will I have to manually change Settings for each type of audio? I was really hoping my nVidia sound would output a raw stream and allow my iScan to do all the work but given how poorly that works with video (there’s no raw video stream output option a.k.a. “source format”) on any video card I suspect I know the answer.

Thanks!

nvidia-bug-report.log.STEREO.17Dec2018.gz (1.03 MB)
nvidia-bug-report.log.DS7.1.17Dec2018.gz (1.01 MB)

You added the wrong option, it’s
Option “ModeDebug” “true”
not
Option “true”

The iScan support just correctly told you what I was telling you before, if you want 7.1 sound, you’ll have to feed it (AAC/DTS) bitstream data, not uncompressed PCM. Feeding it PCM will make it switch automatically to stereo only.
The video/sound card does not have much to do with it, it just transfers what the video/sound application is feeding it and the receiver is then switching to the appropriate mode. In case the application is the Desktop environment, or the test speaker panel, it will always produce PCM, so the receiver switches to stereo.
So you need a video or sound file which contains a 7.1 AAC/DTS track and set the application like VLC to pass-through sound instead of decoding it to PCM.
https://kodi.wiki/view/Samples

My apologies on my mistake. Here is an updated bug-report while I digest the remainder of your post. I’m going to read it a few more times but it sounds like my identifying the log with the sound profile from settings may not be necessary.
nvidia-bug-report.log.profile-STEREO.18Dec2018.gz (1.1 MB)

Update: I tried the 1st 4 options under “12 HD Audio Test Clips” (yes, including the “clip #10”).

I wasn’t sure what I was hearing, I was expecting something out on each channel (for easy identification) but that didn’t happen, even on the ones marked “channel check.”

I did notice for all samples it remained LPCM rather than switching to a different format.

Can you please give me a few clues on how I should proceed? Thank you very much, in advance!