GPIO Interrupt not working on Jetpack 6

Hi,

i am currently trying to capture a interrupt signal in C using the libgpiod library on the Nvidia Jetson Orin Nano DevKit. The Orin is running on Jetpack 6. I previously worked on the Jetson Nano and there, everything worked just fine.
Now on the Orin, i can successfully set the State of a GPIO when configured as Output, but i cant capture an Interrupt. When using gpioinfo, I can validate, that my programm is configuring the GPIO i am using just right, but still the signal is not detected.
I also tried to capture a Interrupt using Pythons Jetson.GPIO, but this also was not successful. Is there anybody running into the same issue?

Note: Under Jetpack 6, SYSFS (meaning /sys/class/gpio/…) access is not available.

Thank you,
Tim

Hi,

Can you at least control high/low output value for that specific GPIO pin?

This is expected.
We remove it on purpose because it was deprecated by upstream Linux kernel a long time ago.

Hi DaveYYY,

Yes, the output functionality is fully working. Only Input is not, whether detecting Interrupts or getting the Input Value of a GPIO. This is not working In C with libgpiod and python with Jetson.GPIO.

Regards,
Tim

Did you set the pin you want to use as input in pinmux spreadsheet?

No, I dit not use the Pinmux Spreadsheet as i had troubles using it.
Is there also a way to set the desired Pin as Input by directly editing the device tree?

Regards
Tim

NO.
Everything has to be done via the pinmux spreadsheet.
We don’t encourage directly modifying device tree about pinmux settings.

Okay. Thanks for the reply. I will give this a try. But I also never set the Pins to Output, or is this Default setting?

You should check the pin you want to use in that file.

I cant really find a good Instruction, on how to load the file generated by the Pinmux Spreadsheet. Can you help me with that

It’s here:
https://docs.nvidia.com/jetson/archives/r36.3/DeveloperGuide/HR/JetsonModuleAdaptationAndBringUp/JetsonAgxOrinSeries.html#mb1-configuration-changes