GPIO not working in Jetson AGX Orin

Hi all,

I’m currently trying to blink a led using Jetson AGX Orin GPIO, but this latter isn’t working, i’m using Jetpack 5.0.2, is there any issue with GPIO controls in this JP version ?

PS : I’m using directly the python Jetson.GPIO library


Hi chakibdace,

Which GPIO/PIN are you testing?
You can find here an simple example about controlling a GPIO on Jetson ORIN:

You can try that to see if this GPIO works at your end.

Best Regards,

Enrique Ramirez
Embedded SW Engineer at RidgeRun
Contact us:
Developers wiki:

Hi @EnriqueR

Thank you for the example, i am using Pin13 (GPIO32), it seems that the GPIO is always in Tri-state, i’ve tried to mesure the volatge through the GPIO but it’s always 1.3V whatever if it’s in LOW or HIGH, the voltage never change.

I’ve tried the pyhton code using Jetson.GPIO but it seems it doesnt work, check my log below, on also how am testing the GPIO.


hello chakibdace,

had you update pinmux config?
this pin by default as following.

                        soc_gpio25_pp6 {
                                nvidia,pins = "soc_gpio25_pp6";
                                nvidia,function = "vi0";
                                nvidia,pull = <TEGRA_PIN_PULL_DOWN>;
                                nvidia,tristate = <TEGRA_PIN_ENABLE>;
                                nvidia,enable-input = <TEGRA_PIN_ENABLE>;
                                nvidia,io-high-voltage = <TEGRA_PIN_DISABLE>;
                                nvidia,lpdr = <TEGRA_PIN_DISABLE>;

Hello @JerryChang

I was able to use the GPIOs, i’ve tried to set all PAA GPIOs at out direction and at 1 the value, so i tested every GPIO and found that in the Jetson AGX Orin :

GPIO PAA.00 is pin 31
GPIO PAA.01 is pin 29

It was not very intuitive, so i’m wondering if there is any method to know or to calculate, which GPIO in sysfs correspond to the hardware pin ?


please refer to Jetson AGX Orin Series Pinmux for the mappings.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.