Gpio pull_up_down mode

I use GPIO to read Digital data from Motion sensor. (Motion sensor detect return 1, vice versa return 0)
I want my input pin in pull_up_down mode by function GPIO.setup() but I received a warning "Ignore pull_up_down "

If found this source in Gpio lib and It not accept to use pull_up_down.

My question is:
How can I use pull_up_down mode to set my input in pull_up ?

hello 111convit,

please refer to Jetson-GPIO sample, such as
you may use the API to detect GPIO state changes. thanks

Hello JerryChang,

I checked this example, It is blocking and GPIO INPUT is in default (value = 1) .

My Gpio.INPut always have value = 1 (3.3 vol). How can I change It to 0 ?
I used function GPIO.setup() with parameter pull_up_down and It return ignore.


hello 111convit,

please check voltage levels match.
the Jetson would normally use a 3.3V “TTL” logic level. it probably fail when using 5V or 1.8V.

Motion sensor response voltage = 3.3v (if detected) , vice versa voltage = 0v

I used jetson.GPIO to read it. But It’s not working.
My problem: when Motion sensor return 1, Jetson read 1 and keep this value (Don’t change when Motion sensor return 0 )

I tested this sensor in Rasp3 and It worked normally.

hello 111convit,

could you please also share the hardware pin connections for reference,

My hardware config :
GPIO.setup(15, GPIO.IN,pull_up_down=GPIO.PUD_DOWN)

I also tested in pin 37 and 23

Do U have any soutions for me?

I really need it.


hello 111convit,

please check this document, Jetson Nano Developer Kit 40-Pin Expansion Header GPIO Usage Considerations Applications Note.
you may also check Topic 76100 for default pull configuration and strength for GPIOs on the Jetson Nano,

I checked this topic and founded

“It is possible to disable the pull completely or change the pull type from pull-up to pull-down or vice-versa, but to change this we need to generate a new default pin configuration for the Nano, which unfortunately at the moment is a bit of a convoluted process, but nonetheless we are working on putting the information together to allow users to change this.”

So any up for this ? Because In newest version, It not accepted to change mode.

I also use the Pin that mentioned in GPIO button seems to latch, maybe wrong resistor value but unsure of cause - #6 by jonathanh but It Not work.

The problem is : When I pulled up Pin the first time, The pin keep value not return to default.

Hi 111convit,
Can you please give the dump of these registers to check your gpio settings:
busybox devmem 0x6000d600
busybox devmem 0x6000d610
busybox devmem 0x6000d620
busybox devmem 0x6000d630

There is no update from you for a period, assuming this is not an issue any more.
Hence we are closing this topic. If need further support, please open a new one.

Is the issue resolved? If not, please provide registers data.