Gpu keeps shutting off

I recently installed ubuntu 22.04 using xorg on an asus viviobook running a geforce rtx 3050 mobile gpu. I’ve installed the 510 drivers and have been able to use the gpu but typically after 1-3 days on I lose the gpu and have to restart my computer to get it back and then everything goes back to normal. I typically notice this happens when using darktable when processing significantly slows down or if I’m launching darktable I get an error saying the gpu isn’t available but it seems to be a wider system issue as if I try to launch davinci resolve which requires a gpu I get an error. I had tried switching to the 470 version but that broke everything and had to go through recovery mode when restarting so I’ve gone back to 510. I’ve tried reinstalling the nvidia drivers and dkms but thats had no effect. As far as I can tell nvidia and xorg are running properly but have had no luck figuring out why it stops working. Any ideas on whats going on? Thanks

Please run as root and attach the resulting nvidia-bug-report.log.gz file to your post.

Running under sudo is generally preferred as under a root session the $DISPLAY variable may not be defined and lots of things may not run at all.

Heres the log, at the time of running the report my gpu wasn’t working if that helps - nvidia-bug-report.log (1.5 MB)

The issue is cuda+system suspend. This AFAIK never worked, after suspend cuda will fail and the driver spills an XID 31. A workaround is to unload/reload the nvidia-uvm module after suspend.

Thanks, from looking around does this command do both the unload and reload?
sudo modprobe -r nvidia

That would unload all nvidia modules which doesn’t work due to the running xserver.
sudo rmmod nvidia-uvm
sudo modprobe nvidia-uvm
after resume should work as long as no application is running that’s using cuda.

Thanks, just had the gpu stop and that was a much easier way to get it going again.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.