Grainy/static video feed from on-board video

Hi,

I’ve just received my tx2 and am currently trying to get the on board camera to display something before jumping into opencv.

I’m using this command:

gst-launch-1.0 nvcamerasrc ! 'video/x-raw(memory:NVMM), width=1280, height=720, framerate=30/1, format=NV12' ! nvvidconv flip-method=0 ! nvegltransform ! nveglglessink -e

to get the video stream to the desktop, which works, but the video itself is very grainy/static-y. Here is a screen shot of the ubuntu desktop:

I have flashed the Jetson using Jetpack 3.3, from here: https://developer.nvidia.com/embedded/jetpack and have made minimal changes since. I have also confirmed I’ve removed the protective film from the camera.

I haven’t found anyone else complaining about this problem so not sure what I can do to debug further. Any help would be welcome.

Thanks!

Can you try 1920x1080?

I tried, and it is just as grainy.

fwiw here is the output of the command:

nvidia@tegra-ubuntu:~/dev/open-cv-test/c$ gst-launch-1.0 nvcamerasrc ! 'video/x-raw(memory:NVMM), width=1920, height=1080, framerate=30/1, format=NV12' ! nvvidconv flip-method=0 ! nvegltransform ! nveglglessink -e
Setting pipeline to PAUSED ...

Using winsys: x11

Available Sensor modes :
2592 x 1944 FR=30.000000 CF=0x1109208a10 SensorModeType=4 CSIPixelBitDepth=10 DynPixelBitDepth=10
2592 x 1458 FR=30.000000 CF=0x1109208a10 SensorModeType=4 CSIPixelBitDepth=10 DynPixelBitDepth=10
1280 x 720 FR=120.000000 CF=0x1109208a10 SensorModeType=4 CSIPixelBitDepth=10 DynPixelBitDepth=10
Pipeline is live and does not need PREROLL ...
Got context from element 'eglglessink0': gst.egl.EGLDisplay=context, display=(GstEGLDisplay)NULL;
Setting pipeline to PLAYING ...

NvCameraSrc: Trying To Set Default Camera Resolution. Selected sensorModeIndex = 1 WxH = 2592x1458 FrameRate = 30.000000 ...

New clock: GstSystemClock

Please do clean flash with Jetpack 3.3. If the issue is still present, it is more like a HW issue and need to contact sales service.

Thank you, I will try and report back. I appreciate your time helping me on this.

Be also sure to have enough lightening of your scene.
In dark scenes, autogain may increase gain that will in turn increase noise.

This definitely made it better but still not 100%!
Do you know of any way to disable or otherwise modify the gain? I would like to ensure there is nothing wrong with the hardware, if possible.

If you are using nvcamerasrc, it depends on nvcamera-deamon. It will autoset exposure, gain, white-balance. You may get better control with nvarguscamerasrc in latest releases.
Otherwise, you may also try V4L interface. Check this post.

Thank you very much for the info!

If you are using nvcamerasrc, it depends on nvcamera-deamon. It will autoset exposure, gain, white-balance. You may get better control with nvarguscamerasrc in latest releases.
Otherwise, you may alos try V4L interface. Check this post You may also use qv4l2 (can be installed through apt) for adjusting your best settings.