gst-omx for latest gstreamer version 1.14

Hello,

Last Jetpack 3.2 b196 release still includes gstreamer 1.8.3.

When will gst-omx plugins work with latest gstreamer version 1.14?

Thanks

Hi Ketchup, the schedule of upgrading gstreamer revision is uncertain. Still under discussion.

Do you see any issue with 1.8.3 and must upgrade to 1.14?

WebRTC support but I guess we could use it by rebuilding 1.8.3.

We would also be interested in a tentative schedule. The webrtc would be really awesome.

I built gstreamer 1.14 using the instructions in the “Accelerated Gstreamer User Guide, Release 28.2” on both TX-1 28.1 and TX-2 28.2. A couple very basic sanity tests work with the onboard camera and Leopard Imaging IMX-274:

gst-launch-1.0 videotestsrc ! xvimagesink
gst-launch-1.0 nvcamerasrc ! nvoverlaysink

We would also be very interested in 1.14 an official statement and support from NVidia. Version 1.8.3 is very old at this point with many bugs fixed and features added in the later releases. New features in 1.14 that are important to us include:

  • WebRTC
  • proxy support enabling decoupling of gstreamer pipelines
  • inter support enabling splitting pipelines across processes

You can manually upgrade to 1.12.4 per user guide https://developer.nvidia.com/embedded/dlc/l4t-accelerated-gstreamer-guide-28-2-ga

DaneLLL - The original post and my response are asking about 1.14, not 1.12.4. webRTC is introduced in 1.14. As already mentioned, 1.14 appears to work in some very simple test cases when installed using the instructions you refer to. Are there any known issues with 1.14 that we should watch out for?

Upgrading to gstreamer 1.14 is under review.

For further business opportunities, please contact your NVIDIA region salespersons.

Hi,

Is there any progress on upgrading TX2 to use Gstreamer 1.14? Please can someone confirm that I can uppgrade to any latest version 1.1x which will not cause any issue on TX2?

Thanks,

PLease upgrade to 1.12.4 as suggested in comment #6

DaneLLL - as previously responded, WebRTC support is introduced in 1.14. This is pretty critical for any interactive video application over the net. It would be really nice to have official support - this is a very mainstream feature.

Hi sperok,
Please consider using Xavier. r31.0.2 is at gstreamer 1.14.1

Are you suggesting that TX2 is approaching end of life?

It is half the price of Xavier, resulting in an end-user price point much lower than a Xavier product could achieve.

Hi sperok,
No, TX2 is not approaching end of life, but there is no plan to upgrade to gstreamer 1.14.1.

Hi DaneLLL,
Thank you for your response. I will upgrade to 1.12.4.

I tried to upgrade using gst-install from 1.8.3 to 1.12.4(as per user guide). Some of the elements(in gst_plugins_good and gst_plugins_base) are not installed by default. I am using jpegenc and clockoverlay which are not installed in the version 1.12.4.

I have looked into gst-inspect which shows less number of plugins. I could not find clockoverlay & jpegenc either.

Do I need to update anything? Is there any other way to install plugins? Please guide me.

Thanks,

I rebuilt all of gstreamer using both the NVidia instructions and the standard Gstreamer instructions for rebuilding all components (good, bad, ugly) a while back and am currently running 1.12.4. clockoverlay is in our pipeline and definitely works. I am under time pressure on a project and can’t provide step-by-step instructions but can confirm that it does work when everything is built following the supplied instructions.

Hi Sperok,

Thanks for your reply. I am building Gstreamer for the first time as I was using installed version till now. I tried to build Gstreamer manually by downloading the source.

I could see from the plugins-good config log,

configure: *** Plug-ins with dependencies that will NOT be built:
	1394
	aasink
	cacasink
	cairo
	directsoundsink
	dv
	flac
	gdkpixbuf
	jpeg
	osxaudio
	osxvideosink
	png
	shout2
	speex
	sunaudio
	taglib
	waveformsink
	wavpack

Same with the plugins-base for few elements.

configure: *** Plug-ins with dependencies that will NOT be built:
	cdparanoia
	ivorbisdec
	libvisual
	opus
	pango

Could you please tell me whether I need to enable them in the Makefile somewhere? or Do I need to do something else?

Thanks

Sorry, it has been a while and my memory is fuzzy. I am sure that I also had many plug-ins that did not get built. Some of them did not matter since they were system-dependent (osxaudio, osxvideo). But clockoverlay is dependent on pango for text handling so I am pretty sure that there is something wrong in your build.

The instructions I followed that worked were from: https://gstreamer.freedesktop.org/documentation/frequently-asked-questions/git.html

Thanks Sperok, I will look into the link and also config.log if can get any clue.