GTX 970 @ 355.11 on FC22 refuses to recognize TV used as monitor upon display sleep resume, TV resta

Update here:

Same system running:
GeForce GTX 970
HDMI 2.0
Samsung Curved 40" 4k (JU6700)
Fedora 23
Nvidia Driver Version: 358.16

I installed KDE via dnf groupinstall kde-desktop-environment to test out the new plasma alongside Gnome. In KDE I can successfully wake up the Television via keyboard and mouse. Weird.

I also submitted a bug report

I have this problem as well with a gtx970 in arch. Driver 361.28. The only kernel message I seem to get is

nvidia-modeset: WARNING: GPU:0: Unable to read EDID for display device SONY TV *02 (HDMI-0)

The “No signal after power cycling a TV using 4K@60Hz” problem appears to be common:

https://forums.geforce.com/default/topic/777734/
https://forums.geforce.com/default/topic/791260/
https://forums.geforce.com/default/topic/810195/
https://forums.geforce.com/default/topic/913773/
https://forums.geforce.com/default/topic/915167/

(I’m subscribing to all those threads, and this one, in case someone finds an answer.)

With Samsung TVs, some people report that disabling “Samsung Instant On” (Menu > System > General) helps. It doesn’t help for me (or a friend with the same problem) – also I believe @sgtnoodle is using a Sony TV, so it doesn’t seem TV-specific.

Some people report that a different HDMI cable helps. It doesn’t help for me (tried several highly rated cables, all have rock-solid picture, all suffer from no-signal-after-TV-power-cycle problem).

Dropping down to 4K@30Hz fixes the problem, but that’s unacceptable of course.

This seems to happen on Linux and Windows. Some people report that downgrading to an older driver version (e.g. Windows 361.43) helps. I need to try that. (Interesting that someone in this thread found the issue was fixed with Windows 361.91.)

I personally went as far as to get an HDFury so I could mess with EDID settings or control when hot-plug occurs, it’s a fun gizmo but doesn’t seem to affect this problem.

(/sub, sorry)

egnor, I have seen the HDMI cable recommendation around as well. I got a new cable and have the same results. Hoping for a driver update soon!

I’ve gone ahead and ordered some active DP 1.2 to HDMI 2.0 adapters as a workaround.

They appear to be backordered everywhere, but I’ll update thread when they come in if they work.

Another datapoint:

Using 364.12, anything over 4K30 fails with “No signal.”

Using 361.28 If I have a different display also hooked up along with the Samsung TV, I can switch sources and it will recover.

With only the HDMI display hooked up, it will not recover.

I can confirm that the Club3D active DP->HDMI adapters fixes the lost signal while switching inputs.

However, turning off the TV and turning it back on again still results in a lost signal. Switching the input away from the NVIDIA card and back will restore it.

It’s not a complete workaround, but at least I don’t have to reboot my installations.

The new 364 driver as far as I can tell made everything even worse.

Okay, here’s the magic formula that works for me:

Club3D DP->HDMI 2.0 active adapter
Samsung UHD Color Mode: Enabled
Samsung Instant On: Enabled
NVIDIA 352 Linux driver

isopede, that is interesting. This still does not help us that are using straight HDMI 2.0. Any one else have any more luck? This is still happening on KDE. I mentioned above that it fixed it, but it was just more sporadic.

We have fixed bug : Wake From Display Sleep Not Working with Samsung Curved 40" 4k (JU6700) in next driver release.

Sandip,

Fantastic news, thank you for the update. What version of the driver should we look for that includes the fix?

Any update on this? Still having this issue and up to date. Any specific versions we should look for?

Looks like this is fixed, fantastic!

cat /proc/driver/nvidia/version
NVRM version: NVIDIA UNIX x86_64 Kernel Module 367.27 Thu Jun 9 18:53:27 PDT 2016
GCC version: gcc version 5.3.1 20160406 (Red Hat 5.3.1-6) (GCC)