GTX 970: Fans always off in all-Linux-distros.

Hello everybody.

I have a problem that no one was still able to solve. I searched everywhere, but seems like no one know the answer, so im asking here for advanced help. Let me explain the problem.

I have an NVIDIA GTX970. It has 4 fans. I installed latest NVIDIA drivers (390.something), running latest Linux Kernel, on many Linux distros. What Happens? At system start, GPU FANS run for 5 minutes, after that, off all the time. Even over 70 Celsius Degrees, nothing Happens, FAN Offs.

Literally, my GPU Burn while doing nothing. Now the question is: whats the problem with your driver? why they cant manage correctly my GPU FANS? I have to leave Linux for this outrageous problem?

How i can resolve? Thanks in advance.

P.S.: I tryied many scripts etc. to automatically run GPU FANS at certain temps, but seems like every tool i tryied just switch on the FANS withouth shutting it off in any case, like the off interrumpt doesnt work when they’re activated.
P.S.2: On windows everything works perfect with GPU proprietary app.
nvidia-bug-report.log.gz (122 KB)

Please run nvidia-bug-report.sh as root and attach the resulting .gz file to your post. Hovering the mouse over an existing post will reveal a paperclip icon.

Thanks, log attached.

When you were running nvidia-bug-report.sh, what was the state of the fans?
According to the logs, nvidia-smi reports a state of fan at 48%, temperature at 40°C. The target fan speed is 0%, though.
What brand is that card, is it some special “Zero Fan Speed” model?

This one: https://www.amazon.it/Inno3D-GeForce-iChill-Air-Boss-Ultra-3-5GB/dp/B00O3IH7DS/ref=sr_1_1?ie=UTF8&qid=1536782364&sr=8-1&keywords=ichill+inno3d+970

As far as i remember, was 0RPM when i runned the log. Need another log when im sure its 0RPM and a temp over uh 60 or 70 degress?

Yes, having a log from around 70 degrees would make things clearer.
Looks like some very custom fan design by Inno3D. Does even the small fan on top of the card stand still? From the sparse info I found, that one shouldn’t even be controllable.
When you use the manual fan control, do all fans turn?
For a workaround meanwhile, did you try this one https://gist.github.com/byaka/6337021
From the looks of it, that should work when making the change mentioned in the comment at the end.

The top FAN is PWM too, it have automatic control.
Yes, when i use manual control from NVIDIA-Settings, all the FANS works.
For the workaround, as far as i can see, that script dont have an automatic way to shut down the FANS. I have tryied a lot of scripts like this, but seems like no one is able to shut down FANS (always active even if the scripts should shut down FANS).

EDIT: tryied that script (with the suggestion of that link), automatic fan regulation work, but FANS NEVER stops (tryied setting “0” inside the script). It’s the same behaviour i obtain every time i try a script like this, can’t understand the problem.

EDIT 2: uh, seems like at something like 70+ degress FANS automatically starts (withouth the script). There isnt a way to make this temp lower?

EDIT 3: seems like, after it automatically goes on, it stops when GPU reach 40 Degress. The other curious thing is that, even if my FANS have more speed steps, in ANY case, they will run at 48% of the 100% (1200 RPM more or less), unless i modify them manually from NVIDIA-Settings.

Here’s the log.

nvidia-bug-report.log.gz (134 KB)

That’s really odd, looks like the linux driver doesn’t get along with inno3d’s tweaks or sensors, it’s always reporting the same 48% fan speed, 0 rpm, 0 target. Since it’s turning on the fan between 60-70 degrees, this looks like it’s at least using the values from the vbios. Som vendors do that, only turning on the fans at that threshold. Maybe use maxwellbiostweaker to take a look at the fan settings.
Still odd why it fails to throttle down the fans.

EDIT modified and uploaded a new log with automatically ON and OFF fans (70 ON, 40 Off). Thx for the tip, i’ll try with Maxwellbiostweaker. If im lucky, i could set FAN speed as i want from GPUBIOS.