HDMI errors while booting

Hello.

I have Xavier NX board.

While booting, there are two types of errors:

[ 0.000000] OF: fdt:Reserved memory: failed to reserve memory for node ‘fb0_carveout’: base 0x00B
[ 0.000000] OF: fdt:Reserved memory: failed to reserve memory for node ‘fb0_carveout’: base 0x00B
[ 0.000000] OF: fdt:Reserved memory: failed to reserve memory for node ‘fb1_carveout’: base 0x00B
[ 0.000000] OF: fdt:Reserved memory: failed to reserve memory for node ‘fb1_carveout’: base 0x00B
[ 0.000000] OF: fdt:Reserved memory: failed to reserve memory for node ‘fb2_carveout’: base 0x00B
[ 0.000000] OF: fdt:Reserved memory: failed to reserve memory for node ‘fb2_carveout’: base 0x00B
[ 0.000000] OF: fdt:Reserved memory: failed to reserve memory for node ‘fb3_carveout’: base 0x00B
[ 0.000000] OF: fdt:Reserved memory: failed to reserve memory for node ‘fb3_carveout’: base 0x00B

and

[ 1.358253] tegradc 15200000.nvdisplay: hdmi: tegra_hdmi_tmds_range_read(bd) failed

BSP is 32.4.4
What it the reason of these error and how to avoid them?
Thank you.

If they don’t affect your normal use on HDMI, then please ignore them.

Hello

In continuation of our conversation about HDMI - we haven’t any visual issues with HDMI, but we have several questions regarding the warnings/errors that we see during the boot sequence (CBoot) // (for easy of reading, we have combined them into bloks)

--------We want to understand what these warnings/errors are and whether it is possible to remove/fix them in a custom build.----------

WARNING: no registered clock for FMON_NAFLL_CLUSTER1 (id 281)

clk_set_parent failed for clk can1, parent pll_aon (-22)
clk_set_parent failed for clk can2, parent pll_aon (-22)
clk_set_parent failed for clk dmic5, parent pll_aon (-22)
clk_set_parent failed for clk i2c2, parent pll_aon (-22)
clk_set_parent failed for clk i2c8, parent pll_aon (-22)
clk_set_parent failed for clk spi2, parent pll_aon (-22)
clk_set_parent failed for clk pwm4, parent pll_aon (-22)

Failed to register PTO counter for id 281
Failed to register PTO counter for id 281
Failed to register PTO counter for id 281
Failed to register PTO counter for id 281

rm_rail_debugfs_init: /rm/vdd_cpu: failed
rm_rail_debugfs_init: /rm/vdd_cpu: failed

[0001.755] E> DEVICE_PROD: Invalid value data = 0, size = 0.

[0001.760] W> device prod register failed

[0001.847] E> I2C: Could not write 0 bytes to slave: 0x00a0 with repeat start true.

[0001.848] E> I2C_DEV: Failed to send register address 0x00000000.

[0001.849] E> I2C_DEV: Could not read 256 registers of size 1 from slave 0xa0 at 0x00000000 via ins.

[0001.857] E> eeprom: Retry to read I2C slave device.

[0001.862] E> I2C: slave not found in slaves.

[0001.866] E> I2C: Could not write 0 bytes to slave: 0x00a0 with repeat start true.

[0001.874] E> I2C_DEV: Failed to send register address 0x00000000.

[0001.879] E> I2C_DEV: Could not read 256 registers of size 1 from slave 0xa0 at 0x00000000 via ins.

[0001.889] E> eeprom: Failed to read I2C slave device

[0001.894] I> Eeprom read failed 0x3526070d

[0002.034] I> tegrabl_tca9539_init: i2c bus: 1, slave addr: 0x46

[0002.041] E> fetch_driver_phandle_from_dt: failed to get node with compatible ti,tca9539

[0002.049] E> fetch_driver_phandle_from_dt: failed to get node with compatible nxp,tca9539

[0002.056] W> tegrabl_tca9539_init: failed to fetch phandle from dt

[0002.062] I> tegrabl_tca9539_init: i2c bus: 1, slave addr: 0x44

[0002.069] E> fetch_driver_phandle_from_dt: failed to get node with compatible ti,tca9539

[0002.076] E> fetch_driver_phandle_from_dt: failed to get node with compatible nxp,tca9539

[0002.084] W> tegrabl_tca9539_init: failed to fetch phandle from dt

[0002.184] I> Found 47 partitions in QSPI_FLASH (instance 0)

[0002.204] W> Cannot find any partition table for 00000003

[0002.278] E> Error -9 when finding node with path /boot-configuration

[0002.280] E> tegrabl_cbo_parse_info: “boot-configuration” not found in CBO file.

[0005.509] W> WARNING: event and command not matching, cmd_trb_ptr = 0xa0ea0800, cmd_ring.dma = 0xa0

[0005.610] I> Start to enumerate device

[0005.611] W> WARNING: event and command not matching, cmd_trb_ptr = 0xa0ea0800, cmd_ring.dma = 0xa0

WARNING: pll_d2 has no dyn ramp
WARNING: at platform/drivers/pg/pg-gpu-t194.c:185
WARNING: at platform/drivers/pg/pg-gpu-t194.c:185
WARNING: at platform/drivers/pg/pg-cv-t194.c:73
WARNING: at platform/drivers/pg/pg-cv-t194.c:73

  1. Which device connected to I2C slave address 0x00a0?