Help for confg CMAKE with OPTIX 7.0

Hello!
Can u help me to install CMake and Optix 7.0???
I cant do this step

The newly added OptiX Introduction examples add a dependency for the DevIL image library.
Set IL_INCLUDE_DIR, IL_LIBRARIES, ILU_LIBRARIES, and ILUT_LIBRARIES to the path for
DevIL/include, DevIL.lib, ILU.lib and ILUT.lib respectively.

I cant found the DLLs.
Thanks!!

Note that the OptiX Advanced Samples are built against OptiX 5.1.0 and while they still run with OptiX 6.5.0, they do not make use of the built-in triangle intersection on RTX boards.
They won’t work with OptiX 7.0.0 at all because that changed to a completely different API.

Instead please have a look into the last post of this sticky thread which contains a link to OptiX 7.0.0 based ports of some of the OptiX introduction examples:
https://forums.developer.nvidia.com/t/optix-advanced-samples-on-github/48410/4

They come with *.cmake scripts inside the 3rdparty/CMake folder to resolve these include directory and link library locations automatically when following the 3rdparty build setup descriptions inside the readme.
The three 64-bit DLLs need to be copied into the executable’s target directory.
The necessary steps are explained inside the README.md there.

Hello and thanks a lot but i have a problem with the part that says

Execute the command 3rdparty.cmd. This will automatically download GLFW 3.3, GLEW 2.1.0, and ASSIMP archives from sourceforge.com or github.com (see 3rdparty.cmake) and unpack, compile and install them into the existing 3rdparty folder in a few minutes.

This says me > “C:\Program Files\cmake\bin\cmake.exe” -P 3rdparty.cmake -DCMAKE_INSTALL_PREFIX=“3rdparty”

cl_version = Compilador de optimización de C/C++ de Microsoft ® versión 19.26.28619 para x64
© Microsoft Corporation. Todos los derechos reservados.

cl_architecture = x64
CMake Error at 3rdparty.cmake:81 (message):
no generator found, exit

Thanks!!

Oh, you’re using a language I haven’t prepared for.

In line 36 of that same 3rdparty.cmake script is a regular expression which looks for the compiler version major and minor numbers after the word “Version” in the output:
string(REGEX REPLACE ".*Version (..).(..).*" "\\1.\\2" cl_version ${cl_info_string})
but your compiler is reporting “versión” which isn’t matched and won’t fill the cl_version variable with just the version number only but the whole output. The following version number comparison in lines 62 to 74 fail then.

There are three possible ways to work around this:

You’re using 19.26 which maps to the range 19.20 to 19.29 (see line 60) which means MSVS 2019.

1.) I don’t know if this works, but one way would be to change that line 36 to
string(REGEX REPLACE ".*versión (..).(..).*" "\\1.\\2" cl_version ${cl_info_string})

2.) If the regular expression doesn’t handle the apostrophe, you could also simply hard-code the cl_version to your version number.
Keep or comment out line 36 and insert this line directly after it:
set(cl_version "19.26")

3.) Hardcode the GENERATOR and MSVC_TOOLSET to your compiler version directly. For that, comment out all lines between 62 and 74, and only uncomment lines 72 and 73 again:
set(GENERATOR "Visual Studio 16 2019")
set(MSVC_TOOLSET "msvc-14.2")

Thanks!! Sorry but now i have problems in final step

image

From that dialog you tried to start the ALL_BUILD project from the debugger, but that is not an executable but the root CMakeLists.txt which controls the solution.

Please first select one of the projects like intro_runtime with Set as StartUp Project (right click context menu on the project name). That project name gets bold in the solution.
Then look at its Properties and in the Debugging options set the Working Directory to the $(TargetDir) or manually enter the executable’s binary folder as described in the README.md in the “Running” chapter.
Then try adding the different command lines given there. (rtigo3 always needs the system and scene description file arguments.)


I get this
And then when i cmd the command intro_runtime.exe it says that it cant find DevlL.dll…

You didn’t follow the README precisely enough, or what I already mentioned inside the first answer:
The three (DevIL repated) 64-bit DLLs need to be copied into the executable’s target directory.
The necessary steps are explained inside the README.md there.
and by that I mean the chapter Building and the last paragraph titled Adding the libraries and data which describes which 64-bit DLLs to copy into the executable folder.

You need the CUDA runtime DLL from your resp. CUDA toolkit installation bin folder and five DLLs from the 3rdparty folder, and the contents of the data folder.
The names of the CUDA runtime and assimp DLL differ depending on the CUDA toolkit and MSVS version you used.

In case you did that, your MSVS screenshot is not on the Debugging options where you need to set the working directory and the command line parameters as described in the “Running” section of the README.

Sorry for the Delay…


This happens.
Thanks.

The Command Arguments field needs to contain only the executable’s command line options, means the text after the executable name.

For the intro_driver.exe you’re starting via the Command field,
either put nothing into Command Arguments (which is the same as if you put --miss 1 for the default constant white environment light)
or --miss 0 --light
or --miss 2 --env NV_Default_HDR_3000x1500.hdr

but not all at once as a semicolon separated list or any of the executable names.

The working directory should be
C:\Users\juan\Desktop\TFG\OptiX_Apps-master\Build\bin\Debug
or if you built it there
$(TargetDir)

Please refer to some Microsoft Visual Studio manual if you have issues with using that development environment.

Nice! Thanks, all works!!