How can I confirm OVS is offloaded by Connect-X5

I’m using Connect-X5 on CentOS 8.

  • kernel version: 4.18.0-147.3.1.el8_1.x86_64

  • Firmware version: 16.27.2008

  • ovs_version: “2.12.0”


I think this document is somewhat outdated:

because I tried to follow steps but the command below is not working on ovs 2.12.0. it’s deprecated

$ ovs-dpctl dump-flows type=offloaded

And I got this type of message again and again when I run this command "journalctl -u ovs-vswitchd "

ovs|00008|dpif_netlink(handler82)|ERR|failed to offload flow: Invalid argument: ens2f0

What I have done is that:

  1. Create a VF from a NIC
  2. Change the mode of NIC to switchdev mode
  3. Configure a offload option for ovs before creating a bridge
  4. Create a bridge and add PF interface as well as VF interface to bridge
  5. Launch a VM attaching the VF

How can I confirm OVS is offloaded by Connect-X5 ?

It will be very helpful if you provide many ways to confirm if OVS is offloaded.


Hello Sangmin,

Thank you for posting your inquiry on the Mellanox Community.

Based on the information provided, you are running a non-supported setup regarding to ASAP^2.

Please review the following RN regarding the supported combinations for ASAP^2 →

Also as you mentioned the UM for MLNX_OFED 4.7, you are running MLNX_OFED 5.0- for you can find the UM through the following link →

Thank you,

~Mellanox Technical Support