How can i enable PMIC-WDT

I followed guide below

How To Enable PMIC-WDT

To enable PMIC-WDT:

1. Change ODM data: set ODM data bits 17:16 to 0b10 before flashing in conf file. (This enables PMIC-WDT and disables Tegra-WDT.)

In the file sudo vim p2771-0000.conf.common, replace 0x1090000 with 0x10a0000.

2. Enter the command:

echo 0 > /sys/module/kernel/parameters/panic

3. Enter the command:

cat /dev/watchdog


echo c > /proc/sysrq-trigger

(The latter command causes the system to crash.)

4. Wait for two minutes. The device reboots. With this reboot, UART logs begin to appear in the mb2 logs:

[0000.203] I> pmic: reset reason (nverc) : 0x2

But console log print pmic: reset reason (nverc) : 0x0

what 0x0 means? and is this guide works?

hello kimjishu,

you may just modify ODMDDATA bits 17:16 in the config file to enable pmic-wdt; it’s 0 to disable and 1 to enable.
bit 16: Tegra Denver Watchdog Timer
bit 17: PMIC Watchdog Timer

In this file

I modified all “ODMDATA=0x1090000;” text to “ODMDATA=0x10a0000;”

but after flashing, result is pmic: reset reason (nverc) : 0x0

(I use Jetson TX2 NX)

hello kimjishu,

you’ve update the wrong file, TX2 NX is using p3636.conf.common.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.