How do i move my rootfs to a sata ssd - TX2 Dev board


What is the recommended way of moving the rootfs to a sata drive?

And how do i install via sdkmanager or commandline tools
directly to sata (sda1).

i tried via sdkmanager wehere i did skip the flash and did everything else.

then i tried:
sudo BOOTDEV=sda1 ./ --no-flash jetson-tx2 sda1
which after a while exited with:
Existing flashapp(/home/me/nvidia/nvidia_sdk/JetPack_4.6.1_Linux_JETSON_TX2_TARGETS/Linux_for_Tegra/bootloader/ reused.
./ --bl nvtboot_recovery_cpu.bin --sdram_config P3310_A00_8GB_lpddr4_A02_l4t.cfg --odmdata 0x1090000 --applet mb1_recovery_prod.bin --cmd “flash; reboot” --cfg flash.xml --chip 0x18 --misc_config tegra186-mb1-bct-misc-si-l4t.cfg --pinmux_config tegra186-mb1-bct-pinmux-quill-p3310-1000-c03.cfg --pmic_config tegra186-mb1-bct-pmic-quill-p3310-1000-c03.cfg --pmc_config tegra186-mb1-bct-pad-quill-p3310-1000-c03.cfg --prod_config tegra186-mb1-bct-prod-quill-p3310-1000-c03.cfg --scr_config minimal_scr.cfg --scr_cold_boot_config mobile_scr.cfg --br_cmd_config tegra186-mb1-bct-bootrom-quill-p3310-1000-c03.cfg --dev_params emmc.cfg --bins “mb2_bootloader nvtboot_recovery.bin; mts_preboot preboot_d15_prod_cr.bin; mts_bootpack mce_mts_d15_prod_cr.bin; bpmp_fw bpmp.bin; bpmp_fw_dtb tegra186-a02-bpmp-quill-p3310-1000-c01-00-te770d-ucm2.dtb; tlk tos-trusty.img; eks eks.img; bootloader_dtb tegra186-quill-p3310-1000-c03-00-base.dtb”
saving flash command in /home/me/nvidia/nvidia_sdk/JetPack_4.6.1_Linux_JETSON_TX2_TARGETS/Linux_for_Tegra/bootloader/flashcmd.txt
saving Windows flash command to /home/me/nvidia/nvidia_sdk/JetPack_4.6.1_Linux_JETSON_TX2_TARGETS/Linux_for_Tegra/bootloader/flash_win.bat
*** no-flash flag enabled. Exiting now… ***

so i manually ran

which executed fine. without major errors but left the system broken.

so i again started the sdkmanager and did a default install to emmc.

thanks for any hints.

There is no tool to directly flash to SATA.

To move rootfs to a SATA drive, you need to manually put the rootfs into the SATA drive first. Then using to tell the kernel to mount rootfs from the specific path.

The method is actually same as “Flashing to a USB Drive” → “To set up a flash drive manually for using as root file system” in below document. But need to change the device node to your SATA.

And dumping uart log for would be helpful if anything goes wrong.

Well, ok. i followed your links and it got me somewhere.

but no full boot from sata yet!

i can boot the rootfs from sata when manually editing extlinux.conf or by editing uboot vars.

but as far as i can see.

the /boot on mmcblk0p1 gets used by uboot
so the kernel gets loaded from mmcblk0p1.

i can work around that by:
mounting mmcblk01 /somewhereer and then
mount -o bind /somewhere/boot /boot

but how can i completly get rid the mmcblk01 writes?


Unfortunately, there is no support to fully boot from SATA. Only rootfs on it is possible.

thanks for the help!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.