How do I troubleshoot extremely low 4090 performance in Ubuntu?

I have 520.61.05 with Ryzen 5600x + Gigabyte Gaming OC 4090 with Ubuntu 22.04(the same problem with Ubuntu 20.04) but only score 4542 in Unigine Superposition - I tried reinstalling drivers/playing with different Composition pipeline settings in xorg.conf.
The frame rate is about 20-40 FPS in 4k.

I have 2 LG 4k displays(hdmi+dp)

CPU Load is very low, GPU also always draws less than 150w(I checked via nvidia-smi)

I thought it was PSU problem (EVGA P2 1600w) but when I run examples with CUDA it uses almost 400 watts.

nvidia-bug-report.log.gz (496.0 KB)

Please run as root while the unigine demo is running and attach the resulting nvidia-bug-report.log.gz file to your post.

Thank you, I have uploaded nvidia-bug-report.log.gz
P.S. Dont know why but uploaded file is 496 kb while mine is 501.2 kb

That’s really odd, everything seems to be fine but the gpu showing 100% load at 160W. I’d suspect a driver bug, unfortunately no newer driver being available currently.
I’m getting twice the score on my 3050 mobile.

Did a clean install of Ubuntu (it install 520.56.06 from Driver manager) and suddenly its +180 FPS (interestingly it uses full power but benchmarks reports GPU utilization only 96% instead of buggy 100%)

However after I installed CUDA which comes with 520.61.05 the problem reappeared.

So current workaround for games is to use 520.56.06.

Had the same issue after installing cuda 11.8, which caused 520.61.05 to be installed as a dependency. Ended up resolving the issue by rolling back to 520.56.06, and, regrettably, uninstalling cuda.

You can get a temporary solution by installing 520.56.06 driver in shell script distribution, then install CUDA 11.8 once again as the shell script instead of package manager, and unselect the driver installation during install, technically it’s still 520 version.

You can also just install cuda-toolkit instead of cuda, this will leave the distro provided driver intact.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.