Performance regression on PRIME system with 520 and later driver series

I ran into a performance regression on a PRIME system consisting of an Intel iGPU and an Nvidia dGPU. I’ve tested all drivers series from 470 onwards on the LTS kernel 5.15.89 on Xorg.

The driver versions I tested are 470.161.03, 495.46, 515.76, 520.56.06, 525.60.11 and 525.85.05. The 470, 495 and 515 series are fine, 520 and 525 are not. The performance drop is substantial in all games I tried:

  • Shadow Tactics: Aiko’s Choice (Native/OpenGL) from 57 to 9 FPS
  • DOOM (Proton/OpenGL) from 49 to 23 FPS
  • Dishonored (Proton/D3D9) from 64 to 7 FPS
  • A Plague’s Tale: Innocence (Proton/D3D11) from 34 to 5 FPS
  • DOOM Eternal (Proton/Vulkan) from 40 to 4 FPS

I always made sure the game process showed up in nvidia-smi pmon. I also tried DOOM and Shadow Tactics: Aiko’s Choice with the latest kernel 6.1.7 as well as XWayland but it made no difference.

I noticed that the GPU fan doesn’t ramp up, but according to nvidia-smi dmon the GPU reaches its full clock speed with all drivers. Although, the power draw differs: I saw over 100W for 515 and older and 70W at most for 520 and 525. I set PowerMizer to Prefer Maximum Performance anyway, but that also made no difference.

Erik Kurzinger commented in this issue that in the 520 series some work has been done specifically for PRIME setups. Since 520 is the series that first showed this regression, I thought I’d mention it in case it’s related.

1 Like

I have the same problem. I have a video card without outputs, not a miner. Looks like nvidia did it on purpose.

Same here, I have a P106-100 6G by Gigabyte which also has no outputs, I assume you have something similar. It’s an old card at this point so I don’t think Nvidia would intentionally, and with no warning, hamper its performance in gaming related tasks, which is what the card was meant to be used for, at least according to the vendor’s product page.

Performance is reduced in all tasks.
The map is old, but pascal is still relevant. Cards like p104-100 are quite powerful so far. Their price is several times less than their counterparts with video outputs. I draw such conclusions because similar cards (gtx 1060) with video outputs do not have such problems. And the second argument is that nvidia already did this a few years ago on winodows, and those cards don’t have modern driver support there.

I wasn’t aware they did this on Windows but I’m still hopeful it’s just a bug.

Performance is reduced in all tasks.

In what tasks have you noticed the problem?

I ran some tests with OpenAI Whisper and I got:

  • 6 minutes and 40 seconds for 515.76
  • 6 minutes and 37 seconds for 525.85.05

With Blender’s Eevee OpenGL engine I get:

  • 42.09 seconds for 515.76
  • 46.49 seconds for 525.85.05

So compute tasks are unaffected and graphical tasks seem fine when frame presentation doesn’t factor in.

Yes you are right. I haven’t checked the software for cuda. But in applications using opengl and vulkan I have very bad results like you.

I hope this is really a mistake, and they will not forget about us

I can second that, seems like there have been a sostantial performance drop even on my system:

seems like that has been a performance drop even in other cases, but introduced with 525 series

Any news on 530 driver?

After update 530.30.02 everything is still broken. Looks like nvidia doesn’t care. There are already 3 branches 520,525,530, with this problem.

I can confirm, I tried the 530 driver now that it’s out of beta and the problem’s still present. At this point any feedback would be appreciated, even just confirmation as to whether or not this is going to be fixed or if Nvidia is cutting support for this class of cards.

I wonder how things are on the CMP 30hx, because these cards support an open driver

On the newest driver 525.105.17 the problem is also not fixed

Any news?

535.43.02 Doesn’t work either, nvidia deliberately killed a whole class of video cards, this is no longer a bug.

Same here.

It’s been a few months now, could we get confirmation that this bug’s not being tracked and won’t be fixed? At least I’ll know if have to look for a replacement card.

Glad I found this topic. I was finally able to use proton with an p104-100 simply switching the driver to 515 on ubuntu. I wonder if this is a problem just on mining cards or any prime system…

I haven’t seen any regular PRIME users complain so far and given how many laptops with Nvidia GPUs there are, it would be strange for Nvidia to completely ignore the issue. I’m fairly sure this only affects GPUs with no outputs, i.e. repurposed mining cards.

That’s sad. Productivity (cuda) still works fine with newer drivers…

i wonder if this is valid also for newer tesla cards. I only have a k20xm around , but for that one I cannot test the latest drivers, since the support stops at the 490xx legacy series