How to enable / activate Hardware engines like PVA, DLA, NENVC on Nvidia Jetson Xavier NX?

When I’m checking the Hardware engines in Xavier NX (using jtop), it’s showing all are turned off. How do I enable the hardware engine PVA? Kindly support.

Hi, please confirm whether these hardware engines are available in Jetson Xavier NX? If yes, how can we enable it?

Hi @rahul7manu, yes these engines are all available on Xavier NX - I think jtop is showing if they are actively in use. So when you run an application that uses them, they should not show as OFF anymore - @Raffaello can confirm.


Hi Dusty,

Thank you for your reply @dusty_nv, It’s exactly such you wrote.
jtop detects the engine running reading from:


1 Like

Hi @Raffaello, @dusty_nv,
Thanks for confirmation. Could you please help me with some sample resource to check pva, nvenc, dla, etc… How can I enable them as well?

I tried running perspective warp example from vpi. Attaching the screenshots before running and while running the code.

Initial state…

While VIC code is running…

They are already enabled, you just need to run something that uses them so they are active. For example, TensorRT can use DLA, certain VPI algorithms use PVA, a GStreamer pipeline can use the encoder, ect.

1 Like

Hi @dusty_nv , Thanks. Understand that.

I’m trying to run rescale, undistort and warping.
These I’m unable to run in backend PVA.

Appreciate if you could point me to a resource (sample code) that uses the backend PVA.


You may want to open a new topic specifically about those PVA functions, but I’d check the VPI samples and see which could be run on PVA:

1 Like

Thanks @dusty_nv . Found pva in convolve2d. Let me check that.

I’ve tried 01-convolve_2d example.
Before running the code

While running the pva code

However, I still don’t see pva engine getting active in jtop. Only vic is running which runs while using vic backend as well.
Carrying out these experiments for a time critical project pipeline that I’m building. I want to use the best backend for the operation.
So, I need to know whether is there something additional I need to do to make them active; like do I need to reflash the jetpack or do something else?

Hi, Kindly respond why it isn’t showing PVA active, when I’m running PVA code?

@rahul7manu I would think it’s more likely that jtop isn’t detecting PVA as active than it is that PVA isn’t actually being used by VPI (which would throw an error). For more in-depth profiling, you can use the NSight tools. Also, @Raffaello can you share how you tested the PVA in jtop?

1 Like

Also check out the DLA github page for samples and resources: Recipes and tools for running deep learning workloads on NVIDIA DLA cores for inference applications.

We have a FAQ page that addresses some common questions that we see developers run into: Deep-Learning-Accelerator-SW/FAQ

1 Like

Thank you @ramc . I’ll take a look at these also for understanding of other jetson modules other than PVA.

@dusty_nv , I guess, we still don’t have a clue about it why it doesn’t gets enabled. Probably, if it’s same for others too; I think this needs to be experimented / tested and confirmed.

However, I’m going ahead with CUDA backend for my tasks. This query can be considered as closed. In case, if you get any update on PVA, please do inform me. Thanks.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.