How to enable multi GPU?


I have 2x 3080, 4x 3060ti, and 1x 3070. Create is auto detecting the 2x 3080’s. How do I enable the rest of the GPU’s?

Thank You.

Hi Csoderholm,
By default, Create and all OV apps detects multi gpu support (mpgu). However, for compatibility reasons, it likes to look for the most powerful gpu, and its multiple ‘identical cards’. It ignores all others. This is done for maximum stability and performance and to spread the gpu load and shared resources evenly. Therefore, by default your 2x3080s are being detected and it’s ignoring your other cards.

To enable ALL cards to fire up, you have to force on full ‘mpgu’ support. To do this go to your .bat file and add the following code flag “–/renderer/multiGpu/enabled=true”

To get there you have to get to your actual launch folder for Create. See graphic below. Go to settings, click on this folder icon, it will open up the windows explorer folder. Find the “omni.create.bat” file and add the code flag above.

The full code in the bat file will look like this:
@echo off
call “%~dp0kit\kit.exe” “%%~dp0apps/omni.create.kit” %* –/renderer/multiGpu/enabled=true

1 Like

How can we use multiple GPU instances in the AWS cloud, such as the g5 12 and 24xlarge with 4 GPUs, and the g5 48 with 8 GPUs?

Also for rendering in View/Create, does the number of vCPUs matter?

Finally, how do we set up OV so we can use spot AWS instances?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.