How to install JetPack on non-Ubuntu Linux ?

I am using other Linux x64 distributions for all my work. The silly JetPack installer refuses to install on them, asking for Ubuntu.
It also appears that there is no Jetpack available to be installed directly on Jetson itself, or I was not able to find it. This seems ridiculous; or I am missing something here?

How can I do TX1 development either natively on TX1 itself or on a Linux distribution other than Ubuntu?

Thank you,

JetPack cannot be used on other distributions. The command line flash tool can, but it won’t do the extra package installs. For command line you’d unpack the driver package on your host without using sudo, then go into the “Linux_for_Tegra/rootfs/” subdirectory, unpack the sample rootfs with sudo, cd back to the “Linux_for_Tegra/” directory, and use sudo to run “sudo ./”. Once this is done, connect the micro-B USB cable to the Jetson with the Jetson in recovery mode. Verify “lsusb -d 0955:7721” has output, and then run:

sudo ./ -S 14580MiB jetson-tx1 mmcblk0p1

…this takes significant time. It also uses about 20GB of disk space…use something like “df -H” to see if you have enough disk space before starting.

If you need packages from JetPack and do not have the right version of Ubuntu host it is very inconvenient, but it isn’t a “show stopper”. If you tried to run JetPack you will have a subdirectory there named “_installer/”. Within this is “Chooser”. Chooser runs on any host…though it doesn’t do much without Ubuntu. One thing it does do as a side-effect is to generate file “repository.json” (you just start “./Chooser”, and exit…no need to do much of anything). This is the file which contains the URLs to various packages (be sure to examine architecture, e.g., you can find CUDA for both arm64 and x86_64…one is for a TX1, the other for a desktop PC). You can use wget on those URLs to get individual packages. The CUDA repository “.deb” file is the first thing you want, and run this to get your host to be able to see CUDA packages under the normal “apt update” mechanism. An example candidate from the repository.json:
(this example URL is from JetPack3.1 after running Chooser on Fedora 27)

I have not tried it, but you can also run the “Launcher” application from the “_installer/” subdirectory on non-Ubuntu hosts…but beware that if you experiment you should try to download components and not actually install with this…I doubt the Launcher would do as expected on a non-Ubuntu host. I simply have not tried, someone brave may want to experiment (one of the steps for package install is setting up networking…I don’t want to mess with my networking, but I already have working Jetsons so I’ve never been motivated to risk that). If successful you will probably have a locally downloaded copy of the correct “.deb” files.