How to modify the knernel on the flash pc ,so USART0 can be on automaticlly?

Hi,
After this post ,I try to modify the dtb files on my flash pc ,so the Orin NX UART0 can be on automaticlly.And I encountered some hitbacks .
Here is my steps.
1.Like the post ,I edited the dtb files on the flash pc.

I cannot attach dtb files here. So just changed the extension to txt. The file content is exact.
temp.dts.txt (431.6 KB)

kernel_tegra234-p3767-0000-p3768-0000-a0.dtb.txt (338.7 KB)
2.I flash the Orin NX.
flash_1-1_0_20240401-223857.log (40.7 KB)
3.I cannot find ttyTHS1 in /dev.
Here is the dtb file in the Orin NX.
kernel_tegra234-p3767-0000-p3768-0000-a0.dtb.txt (338.7 KB)
After I decompile it,I can see the status of serial@3110000 is still disabled.How come?

Any help is welcome.
Thank you.

How did you flash it?
Did you replace the dtb file in BSP?

  1. I use this command to flash.
sudo ./tools/kernel_flash/l4t_initrd_flash.sh --external-device nvme0n1p1   -c tools/kernel_flash/flash_l4t_external.xml -p "-c bootloader/t186ref/cfg/flash_t234_qspi.xml"   --showlogs --network usb0 jetson-orin-nano-devkit internal

2.I replaced the files in my fash pc in Linux_for_Tegra/rootfs/boot.
But I did not change the files in the Orin NX.

You need to replace the file under Linux_for_Tegra/kernel/dtb/, not Linux_for_Tegra/rootfs/boot/.

Hi,

Your solution works. Problem solved. /dev/ttyTHS1 is showing in device nodes.

Thank you