how to set tx2 usb3.0 port worked at device mode

how to set tx2 usb3.0 port worked at device mode? we want use this port to make gadget function

my tx2 is with R28.2

Please refer to https://devtalk.nvidia.com/default/topic/1014096/jetson-tx2/how-to-set-tx2-otg-usb-as-device-mode-/post/5205500/#5205500

hi DaneLLL:

thank for you reply

i have already change the code with both dts and dtsi and i rebuild dtb update to tx2 done

but it also can’t work,when i run echo 0x1 > /sys/class/extcon/extcon0/state

dmesg show me that the 3550000.xudc device mode on

i think my 3.0 host controller is 3530000 xhci host controller

[ 145.836236] tegra-xotg xotg: update_vbus_state: VBUS detected
[ 145.998830] tegra-usb-cd usb_cd: notification status (0x0, 0x10)
[ 146.004920] tegra-usb-cd usb_cd: connected to CDP
[ 146.009740] tegra-usb-cd usb_cd: set current 0ma
[ 146.014461] tegra-xudc-new 3550000.xudc: exiting ELPG
[ 146.023180] tegra-xudc-new 3550000.xudc: exiting ELPG done
[ 146.028782] tegra-xudc-new 3550000.xudc: device mode on
root@tegra-ubuntu:/home/nvidia# echo 0x1 > /sys/class/extcon/extcon0/state

I just wanted to clarify…is this a custom board? If it is the development carrier board, then the USB3 full-sized connector is not wired for device mode and cannot do this. The micro-USB on the dev carrier is wired for OTG, but only for USB2.