how to turn my tx2 fan on ,and how to install ruby and python?

how to turn my tx2 fan on ,and how to install ruby and python?

The fan does not normally run unless under load (without load temperature will not go up enough for the fan to trigger).

If you want to manually test the fan, in one terminal run this to monitor current fan setting:

sudo watch -n 1 cat /sys/kernel/debug/tegra_fan/cur_pwm

Then in another terminal this will turn off the fan:

sudo echo 0 > /sys/kernel/debug/tegra_fan/target_pwm

This will max out the fan:

sudo echo 255 > /sys/kernel/debug/tegra_fan/target_pwm

To search for all packages related to python, this works:

sudo apt search python

That’s a lot of python packages…to see a shorter list of those packages starting with “python”:

sudo apt search python | gawk '/^python/,/^(^pytnon)/'

To list python packages already installed:

sudo dpkg --list | egrep -i python

Chances are your python is already installed, although there is python, python2, and python3.

Ruby is a different story, this is not installed already. A short list of available ruby packages:

sudo apt search ruby | gawk '/^ruby/,/^(^ruby)/'

To see an easier to browse ruby package list:

sudo apt search ruby | less

the fan didn’t turn on…

If the fan did not turn on it may be a hardware problem. Does anyone here know if there is a more specific test for a possible fan failure?

Hardware problem!!!God,how can I fix…

1 Like

Hi JuiTengHsu, when does the fan not work? Did you try unplug and then re-plug in the fan’s plug head to J15? Do you have another TX2 or TX1 to do cross check?

Hi JuiTengHsu,I have the same problem ,Do you solve it?I use the TX2.

i didn’t yet

i had tried replug to J15, but same, the fan won’t turn on ,and when i insert this sudo watch -n 1 cat /sys/kernel/debug/tegra_fan/cur_pwm ,the terminal will said no such file or directory…is my tx2 a faulty product?

1 Like

i just put my fan to the orbitty carrier board ,and when i plug in,it turns on,i’m so confused why it can’t work on the original carrier board?is there some problem with the dev kit’s carrier board?

Did you re-flash the board support package for each? The firmware for Orbitty is different than for NVIDIA developer board…they are interchangeable if you flash the software, but they are not hot-plug interchangeable. I believe at minimum there would be a different device tree.

re-flash the board support package? where to?

The Orbitty supplier would have the board support package for flash. The device tree and other software would likely be custom to this particular board…the Jetson would need to be flashed with the different versions each time the module is moved between a developer carrier board and the Orbitty carrier board.

I tried the commands for the fan, following the same procedure but i got this

bash: /sys/kernel/debug/tegra_fan/target_pwm: Permission denied

Any suggestions on how to get it working ?

Edit : Found the solution. For trying to run the fan, i used the code

sudo ./jetson_clocks.sh

Did you use sudo? Only root is permitted to do these things.

If you did use sudo, then it means the drivers rejected the command. This would come back to the question of whether you have flashed for the device tree on the developer carrier board with the module being present on the developer carrier board, or if this is a different carrier board (which requires a different device tree). Is this a different carrier board? What has been flashed to the module?

Hello,

I can’t turn my fan on TX2 JETPACK 4.2

I have not the files neither the folder tegra_fan (I checked manually)

So when I try to run, I get this error

/sys/kernel/debug/tegra_fan/target_pwm: No such file or directory

Any suggestions on how to get it working ?

Thank you

Hi Theo88,

Please check if jetson_clock can start your fan or not as first step.

Thank you Wayne,

Yes by typing :

sudo jetson_clocks

I get the fan working.

sudo echo 255 > /sys/devices/pwm-fan/target_pwm