I can't QGC for Nvidia Jetson Nano

Hi everyone. I study on a simple autonomus drone. My flight control card is Pixhawk Cube Orange I’m using a companion computer, Jetson Nano (ubuntu 18.04) . I’m trying to use QGroundControl on Nano. But i got some issues. Nano uses ARM64. The problem may be caused by this. What can i do this?

I followed the steps in this link:
https://docs.qgroundcontrol.com/master/en/getting_started/download_and_install.html

the issue:
bash: ./QGroundControl.AppImage: cannot execute binary file: Exec format error

Hi,
We don’t have much experience about this. Found sever links which may help:
https://doodlelabs.com/wp-content/uploads/QGroundControl-and-Pixhawk-Advanced-Setup-v01020.pdf
NVIDIA Jetson Nano for Pixhawk - Pixhawk family - ArduPilot Discourse

And there are jetson community projects:
Jetson Community Projects | NVIDIA Developer
Certain project may be similar to your use-case. FYR.

This guarantees the precompiled binary is for another architecture (probably for a desktop PC). If the code is available in source format, and if there is no architecture-dependent code in this, then you could theoretically just compile on the Jetson and have a working version in the correct arm64/aarch64.

Yes probably. I follow the parts in this link. But i got a problem again. I can’t install Qt. Qt is giving a similar trouble.
[Getting Started with source & builds · QGroundControl Developer Guide ]

I haven’t worked on Qt on a Jetson, but I have seen comments about difficulties from other people. I think there was some sort of workaround to get Qt installed, but I don’t know what the steps were. It is likely that if someone who has worked on Qt sees this, then they could tell you how to deal with Qt issues. Otherwise, you might consider some research on Qt with Jetsons (I just don’t know actual results, especially if a particular release is required).